Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Reicast installation on retropie raspberry pi 4



  • Hi, I'm having trouble installing reicast on retropie on my raspberry pi 4. I originally tried to just install it straight from packages before I knew you needed the BIOS, this obviously didn't work. I downloaded the BIOS and put them into what I believe are the correct folders : retropie/BIOS/dc/data but everytime I try to install reicast it comes up with the same issue as it did when there were no BIOS added.

    Are there new BIOS for the pi4 or is there anything else I need to add? It just says it can't find the packages: alsa-oss libevdev-dev and then just goes back to the blue screen, I've followed what it says in the 'help' section which is to have it in the folders as above. I just presumed the packages it can't find are the BIOS I've added but still doesn't seem to find them even though they are where it says they should be. I have tried several different BIOS from different sources and none seem to work. I have also done an update to make sure everything is up to date and still no joy.

    Any help would be greatly appreciated.


  • Banned

    I don't think the BIOS can cause installation problems. Try to launch retropie-setup scritp, then update retropie-setup script from the first menu and the try to install reicast from source.
    What retropie version did you install?



  • @Jammy27 Well first, remember that the Pi 4 isn't officially supported. So there are no BIOS files specific to Pi 4 as far as I know. I'm about to uninstall and reinstall reicast now to confirm, but I'm pretty sure the bios files are added automatically now. Definitely do not follow the wiki page on setting up reicast, as it's out-of-date imo.

    What does your /dev/shm/runcommand.log say after you try launching a game?

    $ cat /dev/shm/runcommand.log
    


  • @Jammy27 I just reinstalled reicast (from source) and found that the dc_* files are placed in /opt/retropie/configs/dreamcast/data/. So just remove any dc_* files you added manually, then reinstall reicast from source.

    If you have issues with controller config, I would make a new post.

    Also for reference, there are 3 Dreamcast emulators: reicast, lr-flycast, and redream. I think redream is under Experimental Packages. Right now, I run 95% of my games through redream. The performance and graphics are clearly better than the others in general. So I would give lr-flycast and redream a try before spending tons of time setting up reicast.



  • @Jammy27 sorry, just re-read your post and realized you can't even get to the point of trying to launch a game, due to missing libraries. Try running..

    sudo dpkg --configure -a
    

    Then attempt the reicast installation again.



  • @davidgrohl I installed raspbian buster from the retropie website. This is the first time I've done anything like this so still trying to figure it all out. The YouTube vids I've seen all say to just go into optional packages and click reicast and install from source but mine always fails. This led me to think that it was because there were no BIOS files so I've added those to where it says and still fails.



  • @rejesterd yes for some reason it just fails and has done even before I started trying to add BIOS. The only reason I'm trying to add reicast is so I can launch redream from the home screen, but apparently it can't be done without reicast as there is no Dreamcast logo on the home screen without it. All the videos I've seen for reicast are for pi3 which is why I wondered if the files may have changed etc.



  • @Jammy27 hm. As a test, I just uninstalled reicast and rebooted. I can still see the Dreamcast option in EmulationStation, and all the games play fine in redream and/or flycast. So I don't think reicast is necessary.

    Have you tried just adding a rom to ~/RetroPie/roms/dreamcast/? I think once you add a rom, the Dreamcast menu should show up in ES. If you can get to that point, then try installing redream and lr-flycast.

    Dreamcast setup is not an easy process yet, but it's very worth it for running these games on the pi4. It works really well.



  • @rejesterd I'll give that a try and if that doesn't work I'll try installing flycast. I do already have redream installed but can only access it through the desktop at the minute, i think once you have reicast installed then you can select it through the emulators option when loading games. at the minute I can't even get the Dreamcast logo up on emulation station. I do have some roms to add so might add those straight to redream and see if it comes up. I'll give all the above a go and see if I can get it sorted and let you know how I get on. I have read that Dreamcast is a bit of a nightmare to get working but worth it once it's done.


  • Global Moderator

    @Jammy27 Sounds like you're using a 3rd party (RetroPie based) image, the desktop is not included in an official RetroPie and it's not necessary for the emulators/EmulationStation to run.



  • @mitu it was downloaded from the raspberry pi.org website. Once loaded up it starts at the desktop and from there loaded and set up retropie and emulation station.


  • Global Moderator

    @Jammy27 said in Reicast installation on retropie raspberry pi 4:

    it was downloaded from the raspberry pi.org website.

    The image there doesn't contain RetroPie.

    EDIT: if you've performed the manual installation steps (detailed in the docs), then you'll need to use the Buster Lite image and not the desktop enabled image.



  • @rejesterd I followed the steps you put for the reicast install and it's all worked. I see what you mean about the BIOS moving into their own folder too, I checked that out once it had installed. Thanks for your help, much appreciated 👍



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.