Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Spectrum roms not working



  • Wonder if anyone can help me. I have a Raspberry Pi 3 b+ and am having trouble playing my spectrum games. The games themselves load fine but my controller doesn't do anything. The emulator being used is LR-Fuse and the rom file types are z80 and TAP which I've been told should be fine. It's my understanding that retroarch should automatically map certain buttons so in can just play but nothing happens. Any ideas?



  • The spectrum is a computer you will need a keyboard for some games and a keyboard to select a joystick it will vary from game to game. Bottom line is you will need a keyboard and also use game focus mode else hotkeys and retropad binds will get in the way and possibly give you double inputs.



  • @grant2258 thanks for the prompt reply. I have tried it with a keyboard before but to no avail but do remember playing most of my old spectrum games with a keyboard. So would you say the games where a joystick was needed would have been mapped to my controller?



  • Well its not that simple but probably yes. I havet used fuse on retropie to be honest have with standalone though. One thing you have to keep in mind is they joystick type your mapping too.

    The most popular are

    Kempston,
    Sinclair,
    Cursor
    (there are also more)

    Again it would depend on the game I remember using the spectrum and a popular default control for the keyboard was q,a,o,p and space for fire. Usually the games have a selection for joystick type on the screen like 0 for kempston and 1 for sinclair. Just make sure your device selection you choose on fuse matches what your using on retroach controls. Give me some names of the games your having issues with and if i have em ill give it a try when i get the time.

    There is more information here https://github.com/RetroPie/RetroPie-Setup/wiki/ZX-Spectrum



  • @grant2258 cheers mate. Just a few off hand are Impossible Mission, Mission Elevator, Treasure Island, Barbarian and Turrican. This has happened on a few Pi's I've used so it can't be my particular system. Appreciate all your help


  • Global Moderator

    Use the RetroArch menus and in the Controls section, set P1 device type as Kempston. More details about how inputs are handled in lr-fuse are here.



  • @mitu thanks very much. I'll look into this



  • To be fair I have had the same problem since re-installing Retropie. I probably installed lr-fuse from source, so maybe it's an issue with the latest version, but I admit I need to look into more myself. IIRC i could not even get the keyboard to work.



  • @HoraceAndSpider thanks for your input. Ive watched a bunch of YouTube vids where once the roms are on they pretty much work with your already mapped controller. It's quite frustrating as the megadrive and snes roms work fine but older simpler games like Spectrum give me hassle. Any further info you can give would be appreciated



  • @mitu tried this last night and had some success with it thanks. Some games still wouldn't function with my gamepad and had to use the keyboard some games just didn't work. It's almost like there isn't a definitive method to get this to work which is silly but progress is progress


  • Global Moderator

    Some games need both keyboard and joystick to work - so just using the gamepad wouldn't be enough. Do you have a game that should work with the gamepad but it doesn't work ?



  • @mitu I don't remember playing any games on the spectrum that needed the keys and joystick although I didn't play them all and there were 1000s! Some games that aren't working with my gamepad are Mission Elevator and Impossible Mission. Say if the original game needed only the Keyboard - would I be able to play that game using my gamepad somehow buy choosing a particular option?



  • There is no definitive method because that's how Spectrum was. This machine had no definitive control method, unlike SNES, or even other micros, which mostly responded to a certain joystick port.

    If you go to Quick Menu >>> Options, you can then map individual keys to your joypad buttons. And you can find controls for most games at the Worldofspectrum.org.

    Eg here are controls for Mission Elevator:

    Q - Move up with elevator or jump
    A - Move down with elevator or duck
    O - Go left
    P - Go right
    SPACE BAR - Fire in every position.
    
    UP LEFT or RIGHT - Attack left or right
    DOWN LEFT/RIGHT - Examine object(s) in front of Trevor
    

    So you just have to bind QAOP SPACE to your gamepad. Then make game option file in there too so it's saved.

    But this game also allows for Kempston control (huge amount of Spectrum games do). Did you go to Quick Menu>>>Input and chose Kempston as Player 1 input, as it was already mentioned above?



  • @youxia. Hi and thanks for your input on this. Yes I tried Kempston on all the games I tried and it only worked for a few of them. What exactly is Kempston? I remember selecting it as a kid but have forgotten what it relates to



  • Original ZX Spectrum did not have a joystick port. You had to buy and connect an interface for that. Kempston was the most popular one, others were Fuller, Protek, Sinclair, Cursor (iirc). If you chose Cursor or Sinclair you could use the number/cursor keys too.

    I just tried Elevator Action in Retroarch on my PC. It worked fine with my Dualshock4. It should be the same in Retropie. You need to change those options in Retroarch first though: first enable Kempston in Port 1 controls (Device Type) and also enable Sinclair Keyboard in Port 3 controls - so you can actually choose Kempston from keyboard in-game.



  • @youxia thanks very much for testing. Did you mean Mission Elevator? I'll give it a go. I'm not sure Keyboard is a choice in the device types options. They all end with joypad. I'll give it a go and let you know the outcome



  • Sorry, I've suggested myself and tried Elevator Action. But it's the same stuff with Mission Elevator, I just played this and also Impossible Mission using my DS4 and Kempston.

    You need to choose the appropriate options in Retroarch. Sinclair Keyboard is in Port 3, not Port 1.

    As an aside, you should try Mission Elevator on Amstrad, its verison is much superior to ZX.



  • @youxia how do I save the controls? You mention "make game option file" but not sure where in retroarch I do that? Is it save state?



  • If you bind keys in Options then you can "create game options file" there.

    When you choose stuff like Kempston/keyboard in Controls then either Save Game Remap (for individual game) or Save Core Remap (for all the games).



  • @youxia mostly worked on all the games I wanted to play. I was having issue with the text adventures where Q&W wasn't typing anything but then realised they were mapped to some joystick moves so wouldn't have been responsive. The only thing I noticed is that Kempston wasn't always the best option to use my control pad. Spectrum Joystick 1 option worked better on the majority of them. Thanks for your help on this



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.