Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

  • RaspberryPi model: Pi 3B
    RetroPie Version Used : version 4.5.1 with latest updates

    I want to disable the option for save/load states. How i can do this?

  • Global Moderator

    Modify the controller's configuration file from /opt/retropie/configs/all/retroarch-joypads and disable/remove the lines for save/load states. Note that if you re-configure your controller in EmulationStation, the configuration file(s) will be re-created and the lines will be added back.


  • Thank you !


  • Just for interest: what about activating the "hardcore-mode" in Retroachievments?
    AFAIR this also disables the save and load-options.
    Are these options also reactivated if you remap your inputs?


  • Finally i get rid of save/load state functionality. i change the following:

    1- This is for the gamepad.

    From/opt/retropie/configs/all/retroarch-joypads
    i remove the lines for save/load states.

    2- This is for the keybord.

    From /opt/retropie/configs/all/retroarch.cfg
    i change the lines from

    # input_save_state = f2
    # input_load_state = f4
    to
    input_save_state = f22
    input_load_state = f44

    3- This is to hide save/load state option, in rgui quick menu.

    i add to the/opt/retropie/configs/all/retroarch.cfg

    the line quick_menu_show_save_load_state = "false"

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.