Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

small window only with SNES emulator



  • Hi all,

    apologies if this question has already been asked, I did look for it and couldn't find anyone mentioning this exact problem. I've got a strange issue where all of my emulators are displaying fine except the SNES one (the others are NES, PSX, and GBA). The SNES one is just a small rectangle in the middle of the screen. I tried adjusting the aspect ratio from retroarch config, and it does affect the ratio of the small rectangle, but it's still just a small rectangle in the middle of the screen with black borders all around it (I hesitate to even call them borders, cause they're bigger than the image itself).

    Not sure what else to try?


  • Global Moderator

    Please add more info about your system, as detailed in https://retropie.org.uk/forum/topic/3/read-this-first.

    You seem to have changed the video settings for the SNES system - did you change the Windowed Scale or Integer Scale options in RetroArch ?



  • It's a Pi3 Model B, powered from a 5V 3A DC adaptor.
    Retropie v4.1
    emulator is 1.3.6 - Snes9x 2010.v1.52.4
    I loaded the build image from an SD card. I'm sorry but I don't remember the filename.

    I hadn't tried playing around with those parameters you mentioned, but I just did now and the Integer Scale ever-so-slightly changes the size, and the Windowed Scale doesn't seem to do anything.

    Something else that I forgot to mention, which might be helpful for debugging, is that on previous TVs (I've now been using this same Raspberry Pi / Retropie combination on three different TVs), I never had any issue with the SNES emulator (or any other emulators for that matter). It's only since getting a new tv (significantly bigger than the older ones btw) that I have this issue (but as I said, only with SNES; the other emulators are fine). So I imagine there must be a link there.


  • Global Moderator

    Hm, maybe you've set a video mode specifically for the SNES system from the Runcommand launch menu ?



  • That was it! I must've changed that either by accident at some point, or sometime a while ago and not remembered. But either way, I went to the Runcommand menu and chose 'Remove video mode selection' and now it's working perfectly. Thanks!



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.