Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

RetroPi 4.6 retroarch psx emulator broken?



  • When ever I try to start a PS1 game using retroarch psx emulator on RetroPi 4.6 the game fails to start. I copied the relevant parts of the runcommand.log below.

    Executing: /opt/retropie/emulators/retroarch/bin/retroarch -L /opt/retropie/libr
    etrocores/lr-pcsx-rearmed/pcsx_rearmed_libretro.so --config /opt/retropie/config
    s/psx/retroarch.cfg "/home/pi/RetroPie/roms/psx/Cool Boarders 3.cue" --verbose -
    -appendconfig /dev/shm/retroarch.cfg
    [INFO] RetroArch 1.8.6 (Git 36802f7)
    [INFO] Redirecting save file to "/home/pi/RetroPie/roms/psx/Cool Boarders 3.srm"
    .
    [INFO] Redirecting save state to "/home/pi/RetroPie/roms/psx/Cool Boarders 3.sta
    te".
    [INFO] === Build =======================================
    [INFO] Capabilities: NEON VFPv3 VFPv4
    [INFO] Built: May 12 2020
    [INFO] Version: 1.8.6
    [INFO] Git: 36802f7
    [INFO] =================================================

    ...

    [INFO] [Video]: Graphics driver did not initialize an input driver. Attempting to pick a suitable driver.
    [ERROR] Currently active window is not an X11 window. Cannot use this driver.
    [ERROR] [Video]: Cannot initialize input driver. Exiting ...
    [ERROR] Fatal error received in: "video_driver_init_input()"

    Seems like the emulator is trying to use X11. Its a fresh install of retropi 4.6. Is anyone else having the same problem?


  • Global Moderator

    @jmbooth2000 said in RetroPi 4.6 retroarch psx emulator broken?:

    Is anyone else having the same problem?

    I doubt it - how did you install RetroPie ? By default RetroArch is configured to use the gl video driver and doesn't rely on X11 environment to run. Did you do any configuration to RetroArch's default config ?



  • I downloaded the image, burned the sd card, then updated the packages which seems to suggest either the original image was bad or the retroarch package was updated.

    I did copy my old configuration files so its possible something there was incompatible but the same configurations files work just fine on an pi 3b running retropie 4.5 which made me suspect the image.


  • Global Moderator

    @jmbooth2000 How about you install, then update but don't copy the configs back ? Try to do it this way and see if you still the error. Then copy back - one by one - your configs until you figure out which one breaks RetroArch.



  • @mitu Is there anywhere I can find the default /opt/retropie/config files? I don't want to do a complete re-image as I would loose my other changes.


  • Global Moderator

    @jmbooth2000 You can start by checking the retroarch's configuration files.
    There's the general one in /opt/retropie/configs/all/retroarch.cfg. You can replace it with retropie.cfg.rp-dist file that's in the same folder.
    Then there's the psx system's specific configuration file, which should be mostly empty, in /opt/retropie/configs/psx/retroarch.cfg. You can remove it, then re-install the lr-pcsx-rearmed emulator package to create the default again.



  • @mitu said in RetroPi 4.6 retroarch psx emulator broken?:

    /opt/retropie/configs/all/

    restored the distro retroarch.cfg file in all and deleted the psx cfg and reinstalled the package. Still no joy. I get exactly the same error.


  • Global Moderator

    @jmbooth2000 Post the whole /dev/shm/runcommand.log on pastebin.com, maybe there's something that stands out.



  • @mitu Posted https://pastebin.com/wup5VJLK

    Thank you very much for all your help. Hopefully the file helps.
    Thanks
    Jonathan


  • administrators

    This is an issue due to old core overrides. Either remove the pcsx-rearmed configs from /opt/retropie/configs/all/retroarch/config (I think this is the right location)

    or alternatively force the input driver by editing

    /opt/retropie/configs/all/retroarch.cfg and setting input_driver to udev

    eg

    input_driver = "udev"
    


  • Thanks!!! That solved the problem!



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.