Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Emulation station fails to launch or launches in background on PopOS 20.04



  • I have a fresh install of PopOS 20.04 running on an Intel Nuc8i3BEH. GNOME 3.36.2. My display is a 1080p TV.

    I installed Retropie as per these instructions https://retropie.org.uk/docs/Debian/

    Everything installs fine, but when I run emulationstation, the screen goes black for a moment, then returns to PopOS, but I can't interact with anything. I can move my cursor moving at the top of the screen, but I can't interact with anything. I have to manually restart the machine to get back to PopOS.

    I checked the logs, and no errors stand out, but I see this at the bottom of ~/.emulationstation/es_log.txt:

    May 22 19:43:41 lvl2: 	Configuring device -1 (Keyboard).
    May 22 19:43:43 lvl2: 	  Mapping [Key X] -> Up
    May 22 19:43:44 lvl2: 	  Mapping [Key Z] -> Down
    May 22 19:43:47 lvl2: 	  Mapping [Key Return] -> Left
    May 22 19:43:52 lvl2: 	  Mapping [Key Down] -> Right
    May 22 19:43:55 lvl2: 	  Mapping [Key CapsLock] -> Start
    May 22 19:43:56 lvl2: 	  Mapping [Key Escape] -> Select
    

    It looks like Emulation Station did in fact launch, and my keyboard mashing after what appeared to be a failed launch was actually picked up by Emulation Station as part of the keyboard configuration.

    Is it possible that Emulation Station is somehow running in the background, or maybe PopOS is putting it in workspace that I can't access? Maybe my display settings are to blame? I even tried disabling all of my GNOME extensions, but no luck.

    Any ideas? Thanks in advance.


  • Global Moderator

    You need to run EmulationStation from a terminal, not as a standalone program. Run it from an xterm/gnome-terminal.



  • @mitu I am running emulationstation from the terminal


  • Global Moderator

    @codyrushing Can you run it with debugging enabled (emulationstation --debug) and post the debug log on pastebin.com ?



  • @mitu here's the pastebin https://pastebin.com/PRm3aHrF

    I ran it in debug mode, it never appeared on the screen, and then after about 15 seconds, I exited with alt-f4. interestingly, after exiting back out to popOS, it had changed my display scaling from 200% to 100%.


  • Global Moderator

    Are you running into a Wayland-enabled session ? Can you try running without Wayland (straight Xorg session) ?



  • @mitu I was running a normal XOrg session before (which is the default on PopOS), but running emulationstation in a Wayland session worked! Unfortunately, Wayland is pretty unstable in PopOS, but maybe it will work just for running retropie.

    In case anyone runs into the same issue, you have to enable Wayland as described here and it will work.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.