Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Dragonrise USB issues



  • Hi, I'm pretty savvy with computers and technical stuff, but this is my first venture into the world of home-brew arcade machine manufacture! I've built an arcade machine for my grandkids during the lockdown and would really appreciate some help! First of all, the info I need to post....

    Pi Model or other hardware: model 4B 4gb
    Power Supply used: Pi
    RetroPie Version Used 4.6
    Built From: premade image from Retropie burned onto 256gb SD card (class 10)
    USB Devices connected: GeekPi wired gamepad (port 1), 2 x Dragonrise inc. USB modules supplied by "EG starts" on Amazon
    Controller used: are above - 10 buttons on each port with a joystick
    Error messages received: None
    Emulator: ALL!

    So the issue is this.... the GeekPi gamepad works very well, but I have issues with the Dragonrise USB cards. I can set them up easily in ES and they do as they have been programmed. I can use them to launch any game. HOWEVER they refuse to control the game in any way shape or form. The only button that does anything is the player 2 coin button which puts coins in, but that's it! I can then take over with the GeekPi gamepad and all is well.

    I have accessed the RetroArch menu from RetroPie and set the controllers to the Dragonrise Inc. settings and binded (bound?) them, but still no joy. it is worthy of note that neither Dragonrise joysticks or buttons work in the RetroArch menu, but the GeekPi pad does.

    So having spent hours and hours building a dual joystick games system for my grandkids, I may as well have just slung the Pi on the desk and plugged the GeekPi gamepad in!!!!

    PLEASE HELP - so that Grandad looks clever!

    Many thanks.


  • Banned

    unplug all controllers then plug in one dragonrise set it up in es then test also check this setting I changed this myself by mistake https://retropie.org.uk/forum/topic/25548/controller-input-not-saving/4



  • @grant2258 said in Dragonrise USB issues:

    https://retropie.org.uk/forum/topic/25548/controller-input-not-saving/4

    Hi Grant, thanks for that. I unplugged everything and swopped the USB's over on the DragonRise it was better. so I left it at that, disconnect the GeekPi controller and rebooted. Set them up again and Hey presto!

    Appreciate your help.

    Regards

    Glyn



  • @grant2258 Hi Grant. Not sure if you can help, but in a follow up to my q a couple of days ago, thanks to you I now have the DragonRise controllers working. HOWEVER, I cannot seem to get access to the RetroArch settings from within a game like I could before (Hold select and X on the GeekPi) Any advice please?

    thanks

    Glyn


  • Banned

    well only the first controller on your system will do that. Assuming it mapped properly it will work i have no issues with it



  • @grant2258 Thanks. I’ve tried them both but I joy. I’ll keep digging!


  • Banned

    set you controllers up again (only one) in emulation station make at the end you set your hot key to your select button dont skip it. Also unplug your joypad as its select button is probably different from what your have on your dragonrise and thats whats probably set atm

    If that fails we can check what is in your config to see whats going wrong.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.