Please do not post a support request without first reading and following the advice in

PPSSPP - Mapping Problem - Wireless Xbox controller

  • Hi.

    Update... Adding my specs.

    • Raspberry Pi 4 - 4GB model.
    • Power Supply: 5.1V 3A USB-C
    • Retropie 4.6, installed from SD Image
    • Using PPSSPP (not Ir-ppsspp)
    • Controller Used - Official Wireless Xbox 360 Controller with the official receiver.

    I'm having problems mapping a wireless Xbox 360 controller inside the ppsspp menu.
    For some reason, it does not recognize any input from the D-pad at all when I try to remap the button function.

    Up and Down buttons don't work.
    Left button registers as Up
    Right button registers as down.

    The analog works fine. The X,[], O, Triangle buttons are mapped correctly as well.
    There are some other mismatched button functions as L and R, but my main problem at the moment is that the D-pad.

    I have a small 8bitdo controller that maps correctly, but I would prefer to use the xbox one.

    Have someone encountered this problem?

  • Global Moderator

    Please add some info about your system, as detailed in

  • @mitu Thank you.
    I had just updated my post by adding the specs.

  • @theink official Xbox one or 360 controller?

  • @quicksilver Xbox 360

  • @theink Thats odd, im using a wireless xbox 360 controller as well and the dpad just works out of the box in PPSSPP. Try resetting the PPSSPP controller mappings to default. Can you use the dpad to navigate the menus in PPSSPP? When was the last time you updated PPSSPP?

  • @quicksilver
    I had updated the script probably a weeks ago.

    I can navigate inside the menu, but as I said if I want to move up and down I have to press left and right.

    I thought I can easily fix this inside the controller config options menu, but this happens...

    I reach the remapping menu. I press the + button under one of the dpad buttons and press A on the controller to confirm my choice. Ppsspp registers the press of A, but when. I press UP to actually remap the button, nothing happens, untill I finally press some of the other buttons.

    It is weird as the other emulators work fine with the this controller.

  • Global Moderator

    I think PPSSPP uses the SDL2 gamepad API to identify and map controller buttons - it may be worth trying to update it's mapping database.
    Grab the gamecontrollerdb.txt file from and replace the file in /opt/retropie/emulators/ppsspp/assets with it, then try again and see if the gamepad is handled better.

  • @mitu said in PPSSPP - Mapping Problem - Wireless Xbox controller:


    I tried replacing the file.
    Nothing changed.

    I did more testing. I noticed one more thing.
    While I'm on the menu and I push the Left Analog UP, I go down.
    When I press Left Analog UP DOWN I go up.
    Pushing Left and Right work as expected.

    Here is what PPSSPP registers on button press when I try to remap the controls to the XBOX360 controller.

    • Dpad Up - pressing UP does not register anything
    • Dpad Down - pressing DOWN does not register anything
    • Dpad Left - pressing Left registers as pad1.Up
    • Dpad Right - pressing Right registers as pad1.Down

    • O - Pressing B registers as pad1.b3
    • X - Pressing A registers as pad1.b2
    • [] - Pressing X registers as pad1.b4
    • Triangle - Pressing Y registers as pad1.b1

    • Start - Pressing Start registers as ThumbL
    • Select - Pressing Back registers as pad1.back

    • L - Pressing LT registers as pad1.b9
    • R - Pressing RT registers as pad1.10

    • Analog Up - Pressing X registers as pad1.Y Axis -
    • Analog Down - Pressing X registers as pad1.Y Axis +
    • Analog Left - Pressing X registers as pad1.X Axis -
    • Analog Right - Pressing X registers as pad1.X Axis +

    I had also updated the Xbox 360 controller driver.
    No change occurred.

  • @theink try this


    xpad triggers_to_buttons=1 to xpad triggers_to_buttons=0

    Then remap your controller in emulation station. Then try remapping in ppsspp. I had a similar situation where I couldn't get the xbox 360 right analog stick mapped in ppsspp. This fixed it for me.

  • @quicksilver said in PPSSPP - Mapping Problem - Wireless Xbox controller:


    I'm keen on trying that, but that file seems to be inaccessible through my network and I don't have Linux to browse the card.
    It seems to be something in PPSSPP that does not recognize the buttons correctly.

  • @theink from emulationstation drop to the terminal (f4) and type

    sudo nano /etc/modprobe.d/xpad.conf

    That will allow you to edit that file. Make the change I suggested above then press cntrl-x. It will ask if you want to save the changes make sure you say yes. Then type emulationstation to go back to emulationstation. Remap your controller and try PPSSPP again. It's a possibility that PPSSPP isn't perceiving the controller correctly because of that above option.

    You can also try updating the xpad driver in retropie-setup.

  • @quicksilver
    Thank you.
    I will try that in the coming days. I don't have a wireless keyboard at hand :p

    I did a complete test of the Xbox360 controller inside PPSSPP.
    This is a list of the buttons I'm pressing and how PPSSPP recognizes them in the menu.

    Main Buttons
    Back - pad1.back
    Start - pad1.ThumbL
    X-Box - pad1.ThumbR

    Directional Pad
    Up - Don't Register!
    Down - Don't Register!
    Left - pad1.Up
    Right - pad1.Down

    Face Buttons
    A - pad1.b2
    B - pad1.B3
    X - pad1.b4
    Y - pad1.b1

    Left Analog
    L3 - pad1.Left
    Up - pad1.Y Axis -
    Down - pad1.Y Axis +
    Left - pad1.X Axis -
    Right - pad1.X Axis +

    Right Analog
    R3 - pad1.Right
    Up - pad1.Pressure -
    Down - pad1.Pressure +
    Left - Don't Register!
    Right - pad1.TouchMajor +

    Shoulder Buttons
    LB - pad1.b6
    LT - pad1.b9

    RB - pad1.b5
    RT - pad1.b10

  • @theink Have you had any luck with this? I'm running into the same issue with a third-party wireless controller that I got from local Best Buy manufacturer. Weird thing is that it works well with the other platforms like SNES or GBA. First time I set it up, left analog joystick worked fine as well as A, B and Y but dpad, shoulders and X buttons didn't do anything Tried reconfiguring it on retropie setup screen and when I got back into PPSSPP this time dpad worked instead of left analog. Thank you

  • @rodolfoaguilar
    I did not have time to research any further.
    I can only guess what is causing the problem, but it is definitely something tied to ppsspp.

    I guess that not enough people had stumbled on it yet. Hoping for an update from the retropie team working on ppsspp.

  • I have exactly the same problem with a Raspberry Pi4 4Gb installed in a PiBoy DMG handheld game case. The D-Pad functions incorrectly in the same way as the OP.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.