Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

  • Ok, so here's the deal and I cannot figure it out. If I shut down, or reboot the Pi (using either the interface, or sudo shutdown/reboot when it come back on, the resolution is HUGE, and then the games have no sound, after I restore from a backup, everything is fine again.

    I have tried multiple SD cards, and power supplies, same thing

    If I let it go and not restore it get to the point that my monitor says "No input"

  • Global Moderator

    Please add more info about your system, as detailed in https://retropie.org.uk/forum/topic/3/read-this-first.


  • *Sorry it keeps trying to mark this post as SPAM when I use the code box

    @idbl_fanatic said in Corrupt after every reboot:

    Ok, so here's the deal and I cannot figure it out. If I shut down, or reboot the Pi (using either the interface, or sudo shutdown/reboot when it come back on, the resolution is HUGE, and then the games have no sound, after I restore from a backup, everything is fine again.

    I have tried multiple SD cards, and power supplies, same thing

    If I let it go and not restore it get to the point that my monitor says "No input"

    Pi Model or other hardware: 3
    Power Supply used: Argon ONE Raspberry Pi Micro USB Cable Power Supply 5.25 Volts 3 Amps
    RetroPie Version Used: 4.1
    Built From: Pre made SD Image on RetroPie website (retropie-buster-4.6-rpi2_rpi3.img)
    USB Devices connected: 2 Zero Delay
    Controller used:
    Error messages received: None
    Log found in /dev/shm/runcommand.log (if relevant):
    File: (File with issue - with FULL path) ??
    Emulator: N/A (all)
    Attachment of config files:

    For more options and information see

    http://rpf.io/configtxt

    Some settings may impact device functionality. See link above for details

    uncomment if you get no picture on HDMI for a default "safe" mode

    #hdmi_safe=1

    display_rotate=1

    uncomment this if your display has a black border of unused pixels visible

    and your display can output without overscan

    #disable_overscan=1

    uncomment the following to adjust overscan. Use positive numbers if console

    goes off screen, and negative if there is too much border

    #overscan_left=16
    #overscan_right=16
    #overscan_top=16
    #overscan_bottom=16

    uncomment to force a console size. By default it will be display's size minus

    overscan.

    #framebuffer_width=1280
    #framebuffer_height=720

    uncomment if hdmi display is not detected and composite is being output

    #hdmi_force_hotplug=1

    uncomment to force a specific HDMI mode (this will force VGA)

    #hdmi_group=1

  • Global Moderator

    Your information is incomplete - how did you install RetroPie ? Version 4.1 is a very old version.


  • @idbl_fanatic said in Corrupt after every reboot:

    Ok, so here's the deal and I cannot figure it out. If I shut down, or reboot the Pi (using either the interface, or sudo shutdown/reboot when it come back on, the resolution is HUGE, and then the games have no sound, after I restore from a backup, everything is fine again.

    I have tried multiple SD cards, and power supplies, same thing

    If I let it go and not restore it get to the point that my monitor says "No input"

    Pi Model or other hardware: 3
    Power Supply used: Argon ONE Raspberry Pi Micro USB Cable Power Supply 5.25 Volts 3 Amps
    RetroPie Version Used: 4.6
    Built From: Pre made SD Image on RetroPie website (retropie-buster-4.6-rpi2_rpi3.img) WIN32DISKIMAGER
    USB Devices connected: 2 Zero Delay
    Controller used:
    Error messages received: None
    Log found in /dev/shm/runcommand.log (if relevant):
    File: (File with issue - with FULL path) ??
    Emulator: N/A (all)
    Attachment of config files:

    # For more options and information see
    # http://rpf.io/configtxt
    # Some settings may impact device functionality. See link above for details
    
    # uncomment if you get no picture on HDMI for a default "safe" mode
    #hdmi_safe=1
    
    display_rotate=1
    
    # uncomment this if your display has a black border of unused pixels visible
    # and your display can output without overscan
    #disable_overscan=1
    
    # uncomment the following to adjust overscan. Use positive numbers if console
    # goes off screen, and negative if there is too much border
    #overscan_left=16
    #overscan_right=16
    #overscan_top=16
    #overscan_bottom=16
    
    # uncomment to force a console size. By default it will be display's size minus
    # overscan.
    #framebuffer_width=1280
    #framebuffer_height=720
    
    # uncomment if hdmi display is not detected and composite is being output
    #hdmi_force_hotplug=1
    
    # uncomment to force a specific HDMI mode (this will force VGA)
    #hdmi_group=1
    

    @mitu said in Corrupt after every reboot:

    Your information is incomplete - how did you install RetroPie ? Version 4.1 is a very old version.

    Sorry, 4.6 and I used Win32diskimager

  • Global Moderator

    What resolution is your display and how is it connected ? Have you tried forcing a specific resolution through raspi-config ?

  • Global Moderator

    @idbl_fanatic said in Corrupt after every reboot:

    display_rotate=1

    can you explain a little about your setup? obviously you've got a rotated display - what changes did you make to achieve this?


  • @dankcushions said in Corrupt after every reboot:

    @idbl_fanatic said in Corrupt after every reboot:

    display_rotate=1

    can you explain a little about your setup? obviously you've got a rotated display - what changes did you make to achieve this?

    I just added display_rotate=1 to the config file for my cocktail cabinet


  • @mitu said in Corrupt after every reboot:

    What resolution is your display and how is it connected ? Have you tried forcing a specific resolution through raspi-config ?

    Sorry, I didn't see your question, the display is 1280x1024, no I haven't tried forcing it, because I figured that would have nothing to do with the sound


  • @idbl_fanatic said in Corrupt after every reboot:

    @mitu said in Corrupt after every reboot:

    What resolution is your display and how is it connected ? Have you tried forcing a specific resolution through raspi-config ?

    Sorry, I didn't see your question, the display is 1280x1024, no I haven't tried forcing it, because I figured that would have nothing to do with the sound

    So I just forced the resolution, that fixed that, but the game have no sounds


  • Oh, I might add that the start up video has sound


  • @mitu said in Corrupt after every reboot:

    What resolution is your display and how is it connected ? Have you tried forcing a specific resolution through raspi-config ?

    Ok, thank you for pointing me in the right direction, I forced the resolution, which fixed that on start up, then it got me thinking., that was only for the system level, so I started poking around the retropie configs, and set the audio to HDMI, and changed the audio driver to SD12 and everything seems to be working now

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.