Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Some Psx Games Not Loading


  • Global Moderator

    Add some info about your system, as detailed in https://retropie.org.uk/forum/topic/3/read-this-first.

    A verbose log from the emulator, for a game that doesn't work, would be useful to diagnose this.



  • @mitu Hello and sorry for the delayed response.
    Pi Model: Raspberry Pi 4 Model B
    Power Supply: CanaKit USB-C Power Supply
    Version: 4.4
    Build From: Retropie_4.4.img -> Sandisk 32GB micro SD
    USB Devices: WD 1TB External Harddrive
    Controller: DualShock 4
    Error Messages: N/A (or maybe I just don't know where to look)
    Verbose Log: (I've tried to create one, but I can't seem to do it right - I'm new to Linux and using commands to navigate)
    File: G:\retropie\roms\psx\Tomba!.bin + G:\retropie\roms\psx\Tomba!.cue
    (There are a few others, but this one in particular is, at least, the one game I wish worked, haha)
    Emulator: PCSX

    If I can be guided on how to get a verbose log for a particular game, I would definitely supply one if it helps this situation. I'm lost on how to do so. I activated, at least I believe I did, the verbose logging in the retroarch menu, but I am not able to generate one. I would probably just assume it's an issue with my understanding, though I've had issues with retropie not saving any of my adjustments of settings after shutting down. That's a whole other issue, I believe.


  • Global Moderator

    @ToryK13 said in Some Psx Games Not Loading:

    If I can be guided on how to get a verbose log for a particular game

    Check the link I posted earlier - https://retropie.org.uk/docs/Runcommand/#launch-with-verbose-logging. Any reason you're using such an old RetroPie version ?



  • @mitu No, haha. There is not particular reason I'm using an old version. I could have sworn I downloaded the image from this site a few days ago, so I assumed I was up to date. I'm currently updating and am going to try to get a verbose log. It could be because I was on an old version, but when I would select it to collect a verbose log at launch, the setting would reset - along with all other settings. We'll see.


  • Global Moderator

    @ToryK13 Updating through the RetroPie-Setup script will not be enough, I advise you to install the latest image from retropie.org.uk/download/



  • That's what I did. I ended up figuring out the problem after several hours of troubleshooting.
    I'll explain what I did and what I figured out for those who may also have a similar issue.
    I found out that I was just ignorant on how retropie loaded roms. I thought it was all out of my external harddrive, so I loaded the thing with every rom I ever owned. I learned that the roms are actually copied to the micro-sd. I was filling up the micro-sd and this caused every problem I was having with retropie.
    I deleted unnecessary roms, I re-flashed my sd, did every bit of setup I needed (setting up wifi, ect.) then the roms all populated and loaded.
    I was also having an issue with the on-system scraper - now knowing it was because I was out of disk space.
    I was also having an issue with PSX not loading my BIOS and claiming there wasn't one loaded. This was also do to the fact that I was limited on disk space.
    I appreciate your prompt response in helping me find a solution to this problem. Unfortunately for me, my day has been spent troubleshooting and I'm not able to enjoy the progress lol. Off to bed.


  • Global Moderator

    @ToryK13 If you want to keep your ROMs on your external drive, follow https://retropie.org.uk/docs/Running-ROMs-from-a-USB-drive/.



  • @mitu I definitely appreciate the link. Again, I'm new to all of this. Thanks again!



  • @ToryK13 I'm a reasonably new newbie too. I'm trying the external hard-drive hookup this weekend following the above advice/link. I'll let you know how it goes.



  • I just completed setting up the USB loader and it’s working great. I had some trouble, but a fresh flash and a reformat of my drive did the trick. Thanks for the help and advice!



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.