Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

ScummVM 2.2.0



  • Hi @hhromic and @mitu , this time I'm reaching out in advance as the next stable version of ScummVM is not out yet but very close!
    I'm trying to help the ScummVM team with testing the upcoming 2.2.0 version so I tried changing the v2.1.0 tag in the scummvm.sh script to "branch-2-2" to compile from source but I get the following error:
    HUNK #1 FAILED at 3139

    Any tips on how to correctly build this from source?
    Thanks


  • Global Moderator

    The error is from the patch to configure applied by the package. You can comment out the applyPatch line in the scriptmodule and it should be skipped.



  • Thanks @mitu. I tried different ways of commenting the patch line without success.
    I keep getting the hunk error...
    Maybe I'm doing it the wrong way?


  • Global Moderator

    Try commenting/removing the whole if block.



  • Thanks @mitu, I had to remove another option, looks like some settings and patches will need to be removed when they're ready to release v2.2.0. I'm working with the ScummVM team to get the script ready. So far it's looking good and quite a few new games are now supported:

    • Blazing Dragons
    • Eye of the Beholder - Sega CD version
    • Griffon Legend
    • Interactive Fiction games
    • Operation Stealth
    • Police Quest: SWAT
    • Prince and the Coward, English translation
    • Ultima IV - Quest of the Avatar
    • Ultima VI - The False Prophet
    • Ultima VIII - Pagan

    Plus, The Feeble Files that crashes on 2.1.0 runs properly on 2.2.0pre

    I'll report progress on this thread.



  • @GeekOB hey can you outline the other options you commented out please? Would love to give this beta a try and give things like Police Quest SWAT a go



  • Sure @retropieuser555,
    Go to \home\pi\RetroPie-Setup\scriptmodules\emulators\
    Edit the file scummvm.sh (make a backup just in case)

    Line 23: add libfribidi-dev at the end
    Line 37: replace v2.1.1 with branch-2-2
    Remove lines 38-41:

    if isPlatform "rpi"; then
            applyPatch "$md_data/01_rpi_enable_scalers.diff"
        fi
    

    Line 42¨: remove --enable-keymapper

    Save the file and then go to the RetroPie Setup utility, select "Manage Packages", "Manage optional packages", scummvm (not scummvm-sdl1) and install/update from source.
    It will take some time to build, so be patient.

    @Mitu, @hhromic and @BuZz, these changes build version 2.2.0pre successfully. I've tested it with both new and older games and they play fine.
    The ScummVM team is expecting to release 2.2.0 officially at the end of September and they will replace the branch with a v2.2.0 tag.



  • @GeekOB Awesome thanks! Just compiling now and I know scummvm takes absolutely forever to build.

    Btw I think branch-2-2 needs speech marks? I got an error without them so added them in like you had in your first post on here.

    Great job though, will have a peek into some of the games and report back



  • Okay so all the games I had on v.2.1 load ok, haven't found any bugs that didn't exist previously. Also on v2.1 for me the left shoulder menu function was broken and now it seems to be fixed again.

    I notice v.2.2 has a keymapper tab built into the scummvm options menu? Even though we removed it from the build in line 42?

    One bug I have noticed by the way, if you are playing a game and choose to return to the launcher, then try and load another game the display output shrinks and just outputs from the bottom left corner of my TV. I've tested this on 2 TVs and it happens both times. But if you exit scummvm and load a new game from emulationstation the display output is perfectly fine again. So it's not a bug that effects functionality really (as most people run the scummvm games from the .sh files rather than from the launcher I imagine).



  • Odd, I don't have that shrinking menu issue at all @retropieuser555.
    What size and resolution is your display? Did you make any changes to \boot\config.txtor runcommand to force a particular display mode?



  • @GeekOB I do I have forced an HMDI mode when trying to fix the lag I was getting on emulationstation (which wasn't present on my pi3b+ setup)

    dtoverlay=vc4-fkms-v3d
    gpu_menu=256
    hdmi_enable_4kp60=0
    hdmi_group=1
    hdmi_mode=16
    overscan_scale=1

    If it's only happening on my setup than I'm not too worried as it's very simple to work around. Thanks anyway though!



  • Hi @mitu, @hhromic and @BuZz, ScummVM 2.2.0 final is available.
    You can build the new binary using:
    gitPullOrClone "$md_build" https://github.com/scummvm/scummvm.git v2.2.0
    This is in addition to the changes mentioned in the 7th post above.



  • EDIT: Looks like this was already handled above. Nothing to see here.

    @GeekOB there is a patch associated with this module. Will it still work with the new release?

    applyPatch "$md_data/01_rpi_enable_scalers.diff"
    

  • Global Moderator

    @GeekOB Thanks for the heads up, we'll see what modifications are needed for the scriptmodule in RetroPie.


  • Global Moderator

    It's added now in RetroPie, needs an update for RetroPie-Setup and then you can update from source to get 2.2.0.



  • Looks like the binary has been created already @mitu. Installed and working like a charm.
    Thank you!



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.