Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Color Issue: Reds Appear Blue, Etc



  • Sorry, I am new to the Raspberry Pi, RetroPie, and the forums here in general, but I have tried a bit of troubleshooting on my own and seem to be getting nowhere. I tried searching the forum here for this issue, and while I found a couple posts related, none seemed to be dealing with the issue "out of the box" but had it crop up while they were editing other configurations. None of the solutions I saw on the other posts seemed to work.

    The gist of the problem is that color reproduction is wrong. The most obvious symptom is that reds appear blue, and I am not 100% sure, but I think that red isn't being transmitted at all which causes the other colors to appear off as well. I have included some photos at the bottom (please accept my apologies for them being upside down. I am not sure why it is doing that? On my computer they appear right side up, but when I attach them to this post it includes them upside down. I hope it stills illustrates my issue.)

    The issue existed the first time I powered the unit on, and it seems to start from the moment it boots (you will see in the photo the first boot screen with the 4 raspberries on it has blue/purple raspberries). It persists throughout the entire run of retropie, from the menus to all the games I have tried.

    I also had no audio when I first launched RetroPie, but was able to fix my no audio problem by adding hdmi_drive=2 and hdmi_force_edid_audio=1. However, in reviewing the rest of the config.txt I did not see anything that appeared to address color that I could edit.

    Hoping people here have seen this problem before and can guide me to steps I might try to fix it. If you need any additional info on the setup or to get logs or something, please let me know and bare with me in terms of providing the exact info as this is my first foray into this kind of tinkering. Thanks in advance for any help you all can provide.

    Pi Model: Pi 3, Model B, 1GB RAM
    RetroPie Version Used: RetroPie 3.8.1
    Built From: SD Image, using Apple Pi Baker for OSX
    USB Devices connected: PS3 Controller, USB thumbdrive with games, keyboard
    Controller used: PS3 Dualshock 3
    Error messages received: None, but the color issue described above exists
    Guide used: Lifehacker Guide and RetroPie wiki
    Emulator: All of the emulators I have tried have this color issue, also the front end UI
    Attachment of config files: I can provide my config file if needed, but it is the default RetroPie 3.8.1 config file, the only modifications made are the audio changes to make audio work over HDMI, specifically hdmi_drive=2 and hdmi_force_edid_audio=1
    Television & Hookup: RetroPie is hooked up via HDMI to an 8 year old Westinghouse TV. TV has recently been tested with several other devices on the TV which all reproduce correct colors, and I have tested several HDMI cords and other HDMI inputs on the TV with the Pi to make sure it isn't that either. It's billed as a 720p LCD but it's true native resolution of 1360x768 for some reason.

    0_1470836605140_IMG_4153.JPG 0_1470836617751_IMG_4149.JPG 0_1470836620925_IMG_4150.JPG 0_1470836623994_IMG_4151.JPG 0_1470836627076_IMG_4152.JPG



  • @ElwoodJD I don't know about the color issue. But that splashscreen looks cool with inverted colors



  • You need to rule out possible causes.

    First, connect some other device using the same HDMI cable. A blu-ray or DVD player, an XBox, your cable TV receiver, etc.
    If the colors are fixed, this proves the problem is with your Raspberry Pi.

    If not, grab another HDMI cable. Connect the same device you just used.
    If the colors are fixed, this proves you had a bad HDMI cable. Use that cable to connect your Pi.

    If after troubleshooting you still think the Pi is at fault, I would try different settings for hdmi_group and hdmi_mode. The settings are laid out here: https://www.raspberrypi.org/documentation/configuration/config-txt.md

    If after having ruled out problems with the TV and the HDMI cable and the display mode you still don't see reds, you may just have a hardware problem with your Pi and need to return it.



  • Thanks for the response. I have tried connecting another device with the same HDMI and the colors are fine, and I have tried using a different HDMI cable with the Pi, same issue persists but only with the Pi.

    I appreciate the link to the hdmi group and mode settings page, somehow when I was looking around I didn't stumble upon those settings. I will play around with those and report back.



  • THANK YOU SIMONBELMONT! Editing those settings sure did the trick!

    I feel a bit stupid, as I did tinker around inside the config file but did not stumble upon the relevance of the hdmi group and mode settings when I was perusing the config wiki page (mostly because I had the proper aspect ratio and refresh rate, or so I thought). But that was definitely the issue.

    For anyone else with similar problems, editing the group and mode to force a compatible setting is the key for this issue. I was able to get the colors right with group=1 and mode= 4. Now the new problem I have is that when I set it to 720p it only fills up a small portion of the screen (even though it claims to be 720p TV) but I am sure I can fiddle with the proper mode setting and /or height-width settings to get it to fill the screen.
    EDIT: Was simply a matter of disabling the overscan within the default config file, got the correct aspect ratio, correct colors, and sound.

    SimonBelmont, thank you again so much for pointing me to the right settings. So I was so worried I would have to return the Pi and get a new one, so I am glad that at least I am on the right track here.



  • @ElwoodJD You're welcome!

    You need to play with the overscan settings next. If I remember correctly RetroPie has overscan turned on by default. It was a bit overzealous on my TV too, leaving too much space at the top and bottom. You'll have to play with the overscan_left, overscan_right, overscan_top, and overscan_bottom settings to make it work for your TV.



  • ElwoodJD, I had the exact same problem and I also have an old Westinghouse TV. I just wanted to add more details to the fix for whoever has this same problem. I am using RetroPie 4.1, I had to go into the RetroPie menu, select File Manager, select /.. twice to get to the root, the select /boot. Select the *config.txt file and press F4 on the keyboard to edit it. Add the following 2 lines to the file hdmi_group=1 and hdmi_mode=4. Press crtl-O to write the file and crtl-X to exit the editor. Hopefully this will help anyone else who experiences the same or similar problem.


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.