Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Anyone get an Xbox One controller working?



  • I'm running RetroPie 3.7 on a Raspberry Pi 3 Model B, but for the life of me I can't get my Xbox One controller to work while I'm in any emulators/games. It works fine in Emulation Station. I've seen tutorials and YouTube videos of people using their Xbox One controller in games, so I'm not sure what I'm doing wrong.

    I'm using the original (not the new one with 3.5mm jack) wireless model connected via the MicroUSB port. I've enabled xboxdrv from the RetroPie Setup Script; tried blacklisting xpad; changed the driver in /opt/retropie/configs/all/retroarch.cfg from udev to sdl2 and back again. If I go into the RetroArch GUI to Settings > Input > whichever "user" lists my Xbox One controller > Bind All, I can map all of the buttons but afterwards it still doesn't work.

    Also, when starting up a game I see something to the effect of "Xboxcontroller(userdriver) configured" flash in yellow text on the bottom left corner of the screen, but obviously it still doesn't work.

    Does anyone have any suggestions? Maybe the current version of of xboxdrv isn't compatible with Xbox One controllers? Or maybe RetroPie 3.7 and/or the Raspberry Pi 3 Model B is incompatible with Xbox One controllers? Or maybe I'm way off.

    My iBuffalo SNES controller works perfectly fine so I can play as much (S)NES as I want, but I'm REALLY getting the itch to play some N64. Help!



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.