Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Save and Load State hot keys not work working on SFC30 gamepad.


  • I was checking out my newish SFC30 pad on my retropie and I noticed a weird problem. My hotkey (START+SELECT) for exiting works fine on this game pad but my hotkeys for save and load state (SELECT+ R) and (SELECT + L) respectivly are not working. Oddly enough L and R work in their intended way inside every emulator. I am not sure what the issue is, but I suspect it may be my config file file for the SFC30 here it is:

    input_device = "8Bitdo SFC30 GamePad Joystick"
    input_driver = "udev"
    input_r_btn = "18"
    input_save_state_btn = "18"
    input_start_btn = "22"
    input_exit_emulator_btn = "22"
    input_l_btn = "17"
    input_load_state_btn = "17"
    input_up_axis = "-1"
    input_a_btn = "11"
    input_b_btn = "12"
    input_reset_btn = "12"
    input_down_axis = "+1"
    input_right_axis = "+0"
    input_state_slot_increase_axis = "+0"
    input_x_btn = "14"
    input_menu_toggle_btn = "14"
    input_select_btn = "21"
    input_enable_hotkey_btn = "21"
    input_y_btn = "15"
    input_left_axis = "-0"
    input_state_slot_decrease_axis = "-0"

    Are my save/load state commands not setup properly? I can't seem to figure it out?


  • Its "Select" that enables hotkeys, not "Start".


  • @Floob My apology I meant SELECT. I edited my issue. Still doesn't work with Select.


  • @silentq what systems is this happening in? have you tried giving better permissions to to folder you are trying to save in? By default the /home/pi/RetroPie/roms/"name of system" i just give permissions to the whole roms folder. Works for me after i do.


  • Tried in NES/SNES/Genesis what's odd is the same hot key works with the DS3 so I am not sure if the SFC30 is different in some weird way?


  • @silentq This might be a dumb question, but here it goes: are you using RetroAchievements hardcore mode?


  • Nope no achievements.


  • @silentq Can you save/load state normally via RGUI?


  • Just checked, yes it works through the RGUI menu.

    Update 1: very odd, the hot key works for the load state (SELECT + L) so it appears its only the save state hotkey not working.

    Update 2: Ok so it appears I can save state but without any consistancy I have to spam it and if I spam (SELECT + R) too much it complete unpairs the controller and I have to re-pair it to get it working again. So perhaps its something just with the build quality of the SFC30?

    Its not the worst thing I can always going in the RGUI and save/load.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.