Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

USB Joypad (Teensy) appearing as 2 joysticks



  • And its usually only the 'up' button that it lets me configure, I can hold any button to get into it, but can then only configure the up button!



  • I've made my own topic as it seems this is one of the two issues I'm having :-)

    Thanks



  • @meleu said in USB Joypad (Teensy) appearing as 2 joysticks:

    @Finndersen I don't know the reason of your device being detected as 2 joysticks. But there is a workaround to solve your joy2key issue:

    Edit your /opt/retropie/configs/all/autostart.sh and put this line before the emulationstation command:

    export __joy2key_dev="/dev/input/js1"
    

    Hi, thanks for the tip, this works to enable the controller in Runcommand, but not Retropie Setup!



  • @Finndersen uhmm... yeah, I think know where the problem is... try to put this same line in your /home/pi/.bashrc. When I get home I'll try to find a solution for both situations.
    [edit: the .bashrc doesn't solve this problem :( ]



  • @lycrake said in USB Joypad (Teensy) appearing as 2 joysticks:

    Hey there, I've got exactly the same problem. I have had it working, but in my tinkering on my portable project its stopped working! JS0 is created, and does nothing and when I test js1 in jstest all my buttons work.

    I'm using the default "Complete" code that came with the Teensy LC, and that has definitely worked before.

    I've tried to add "export __joy2key_dev="/dev/input/js1" to autostart.sh and that hasn't made a difference!

    Retropie automatically pulls up "Gamepad 1" and it won't let me set any of the buttons, can't skip it and the keyboard wont work (apart from F4 to quit)

    Any ideas???

    Hey so I've fixed the Teensy problem.
    Update your Arduino and Teensyduino, then there's a new HID mode you can select, Flight Control Sim and Joystick, choose that and now there's only js0
    You will need to reconfigure controller though



  • I did solve this, i did follow this https://www.raspberrypi.org/forums/viewtopic.php?p=826901#p826901 and now it works.



  • @gunnarh
    All I see there is explaining the way the buttons are wired up, that wouldn't affect how the Teensy acts as multiple joysticks



  • anyone found the solution to this problem ?????????? plz help



  • Has anybody found a solution to this problem yet? I'm facing the same situation. (Yes I know this topic is old)



  • Fixed my problem. Figured I'd post the resolution in the event that somebody else inevitably has the same issue. gunnarh's posted solution was right. It's not an issue of the multiple joysticks. It's actually the sketch. You need to use the bounce library, like was used in gunnarh's link. Without it, the buttons don't get recognized properly within retropie. I went as far as to edit the usb_desc.h for the teensyduino libary to only have it expose the joystick, and nothing more. That worked for only having a single joystick show up, but the button issue remained. It wasn't until I utilized the Bounce library, that my button presses behaved as I expected.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.