Please do not post a support request without first reading and following the advice in

Controller and keyboard suddenly doesn't work.

  • Pi Model: 3B
    RetroPie Version Used: 4.0
    Built From: Pre made SD Image on RetroPie website
    USB Devices connected: Buffalo Classic USB controller (SNES)
    Controller used: See above
    Error messages received: "Gamepad not Detected"
    Log found in /dev/shm/runcommand.log (if relevant): Unable to access.
    How to replicate the problem: Turn console on.

    Hey everyone.

    So I'm in a bit of a pickle. I made a retropie console for my brother so he can play the old SNES games he used to love. I set everything up with the above controller and everything worked great. I shipped it to him, he set it up, and everything still worked great. Unfortunately, today he called me and said when he turns the console on he gets the notice "gamepad not detected, please hold A to configure or press f4 to close". Holding A on the controller does not work, and connecting a keyboard and pressing f4 also doesn't work. So neither the controller nor the keyboard seems to be connecting. I'm in a different part of the country from him, so I can't troubleshoot it directly, I can only do so through skype with him.
    Now, I don't know whether this has anything to do with the controllers/keyboard not working, but apparently just before he noticed they stopped working, he was trying to connect his ipad to the raspberry pi through bluetooth (he's not too tech savvy, but very curious). I don't know how that would cause this issue, but it's apparently the last thing he did before everything stopped working.
    Also, the keyboard he was trying is backlit, can the Raspberry pi handle a backlit keyboard (1 usb plug)?

    I've had him turn the console off and on.
    I've had him unplug and replug the controller and keyboard.
    I've had him try a ps3 controller via USB which also didn't work (though it wasn't charged, I'm having him charge it overnight and will retry).
    I had him plug the USB flash drive in, and the activity light flashes, so it seems USB devices are connecting and transferring data.

    I'd appreciate any help, he absolutely loved this little console and I want to get it back up and working as soon as I can!

  • Is the pi connected to a LAN? I'm asking it because you can connect to to it via SSH and investigate what is happening. Maybe your bro needs to configure port forwarding in his router to let you connect to his pi...

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.