Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Connecting to Wifi networks with Cana Kit Wifi adapter not always successful



  • Ive had this issue intermittently in the past, but i am really just curious at this point if anyone else has had the issue. i would like to fix it if possible.

    With my canakit wifi dongle, i am unable to connect to some networks. i can connect to my neighbors wifi, but not my own nor the network at my office. Also, i am able to connect to my phone wifi hotspot.

    About a year ago, i was connecting fine to my very same router that i am using at home. I changed my SSID and some other things when i mived to a different house. So the hardware is the same, but SSID and password are different. not sure why this would affect my ability to successfully connect.

    Pi Model: 2 B
    RetroPie Version Used: RetroPie 4.04, Linux Raspbian Jessie 4.4.21-v7+
    Built From: Pre made SD Image on RetroPie website, updated with updated RetroPie-Setup Script 10/17/2016
    USB Devices connected: Cana Kit Wifi Adapter (Chipset Ralink 5370), Logitech K400 Keyboard, PS3 Dualshock via USB
    Controller used: Logitech K400 Keyboard, PS3 Dualshock via USB
    Error messages received:
    Guide used: https://github.com/retropie/retropie-setup/wiki/Wifi
    Attachment of config files: using vanilla wpa_supplicant.conf file for wpa/wpa2
    How to replicate the problem: retropie-setup.sh>configuration/tools>wifi - configure wifi> choose network, enter password
    dialog shows "Connecting..."
    I am not at home right now so i can post the exact dialog i am seeing when it fails to connect. either says something like 'Connection failed" or "couldnt connect" or something along those lines; nothing complex.



  • It's been a slow day here at the office so i have gotten to play around a bit with my setup (limited to SSH mostly, except when using coworkers monitor, since mine have no HDMI).

    Either way, i've connected to several different wifi networks and cannot replicate the issue here. I will try some more when i get home to see if all is well. will mark issue as resolved as per outcome.



  • i figured it out- By default the default localization options were set for England. I changed it for UTF 8 and all is well now. I checked my wpa-supplicant.conf and saw a foreign symbol in place of my #. problem solved.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.