Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

UAE4Arm + 8Bitdo FC30



  • Hi guys, wondering if you could help here....

    For my 34th birthday, I got a new Pi 3 and an FC30 controller. Yes; I'm a child in grown ups clothes. ;)

    Now I've got the FC30 firmware updated to the latest (2.69). With the stock firmware (2.6x) it would pair up fine, but Emulation Station saw the D-Pad arrows as Keyboard and the ABXY as the pad. Stranger still, when on USB the pad worked fine in ES. Updated the firmware and this was all fixed. ES works fine now when connected via Bluetooth.

    However... UAE4ARM. No matter what settings I use in Input (Nubs, Joystick, DPad, even the FC30 item in the list) none of the games want to use the controller properly. I'm clearly doing something wrong.

    So far I have only had time to try two games...

    1. Sensible World Of Soccer; This seems to ONLY want to work with the keyboard. I can live with the keyboard being required for the main menu (although dpad would be nice) but when it comes to launching the match the only settings that "work" is the Nubs setting and that means I have to user Arrows + Page Down on the keyboard. This has two issues: 1) It's not my FC30... 2) I can't make the players run diagonally AND shoot (some kind of keyboard buffer limit?!)

    2. Stunt Car Racer; This was a strange one... The FC30 "worked" on the cheat screen when the game loads (eg unlimited turbo) - although I could only go up and down 1 item if I held the buttons, but at least it responded! But once in the game I was back to keyboard control.

    In both instances, the keyboard control only works when on Nubs mode.

    I have not tried UAE4All... Main reasons are:

    1. UAE4All doesn't appear to support and CLI arguments so I cannot get ES to launch games directly. UAE4Arm does support CLI parameters so I can launch games directly with custom .uae files.
    2. UAE4All appeared to be a dead project in GitHub compares to UAE4Arm... https://github.com/RetroPie/uae4all2 (2 years since a commit) vs https://github.com/Chips-fr/uae4arm-rpi/ (1 month).

    Has anyone had any luck getting joypads to work with UAE on the Pi?

    Unrelated: The Pi3 ROCKS for UAE; I can get high end A1200 realtime speeds and the CPU is running half idle!



  • @njt1982 Look here and also some of my post.

    guide-advanced-controller-mappings

    This is what you probably are looking for.
    Sadly i have not been able to get a system wide configuration working but im now at emulator specific configuration.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.