Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Setting up multiple controllers issues



  • I have two identical pc-xbox360 controllers.

    I am trying to map them both to but am struggling to get the second one working correctly.

    I have tried using the GUI in retropie but despite setting up every button only a few work in game, (all emulator settings are default). For Instances, I cant use start and select to exit the game.

    I have tried editing retroarch.cfg to add mapping for a second controller by copying the mapping made by the first controllers only changing it to player 2. e.g. input_player2_btn_a = "3", but this didnt make any of the buttons work.

    Any idea guys on what I am doing wrong.

    I a running on Pi2
    retropie 4 stock.



  • @sirus505
    If they are identical there's no need to configure both. When you configure a controller in emulationstation, a retroarch config file for this controller is created at /opt/retropie/configs/all/retroarch-joypads/. The filename is usually something likeYourControllerName.cfg.

    When retroarch starts it tries to find a config for the connected joysticks in that directory. Joysticks with the same name use the same config file.

    If you look into these joysticks config files you'll notice that they don't use the *_player1_* option. Example:

    input_a_btn = "0"
    

    And NOT this:

    input_player1_a_btn = "0"
    

    And about the start+select to exit game, it only works for player1.



  • Thank you melue for clearing that up. Just thought I could make both controllers have the same privelages in terms of saving and exiting for games.



  • Just have to figure out the issue with moonlight now. Second controller on there works for some games. Not too sure the issue there. Tried asking on Nvidia for answers but not much luck.



  • @sirus505 said in Setting up multiple controllers issues:

    Just thought I could make both controllers have the same privelages in terms of saving and exiting for games.

    There's an option named all_users_control_menu, but it's so new that isn't available in a fresh 4.0.2 install. If you install/update retroarch from source you'll get it.
    I commented about it here
    https://retropie.org.uk/forum/post/24548



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.