Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

"RetroArch configs using RetroPie-Setup configeditor don't persist after reboot".



  • Hi everybody,

    I've tried several ways to change the /all/retroarch.cfg but none of them managed to keep my modifications after a reboot of the Pi. What I just did before posting to try once again is using the configeditor from the Retropie menu: changed this:
    config_save_on_exit = "true"
    and also changed few other things like switching player1/player2 index :

    input_player1_joypad_index = 1
    input_player2_joypad_index = 0

    finally pressed TAB then OK to save it, then edited /all/retroarch,cfg using winSCP to check if my modifications were saved which was perfect.
    Then QUIT Emulation station and reboot the Pi and guess what...the original skeleton of retroarch.cfg is back again in place of the one I ve just modified!
    I really appreciate any help coz it start to make me crazy.

    Here is my setup:

    Pi Model: 3B
    RetroPie Version Used: 4.02
    Built From: Pre made SD Image on RetroPie website
    USB Devices connected: Xin Mo 2 Players
    Error messages received: No
    File: /all/retroarch.cfg (and other retroarch.cfg located in the different system directories)
    Emulator: All

    Here is a post of a guy who add maybe something like the same issue but on PC:
    http://libretro.com/forums/showthread.php?t=6368

    @meleu thx for your support you already gave



  • @FAB2TB SOLVED: My SD card has a writting problem, I cant format it no more which explain that I cant save anything on it correctly since it has been damaged.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.