Please do not post a support request without first reading and following the advice in

"Unable to connect to [WiFi] network" - what now?

  • Any reason why my RP3 and RetroPie can see this network, but cannot connect? It is my only available WiFi and I'm stuck without it.

    0_1479525865651_Screen Shot 2016-11-19 at 4.20.16 PM.PNG

  • Okay, I've found the problem - WiFi passwords with special characters are obviously not being properly hashed when stored, as resorting to an alphanumeric password worked. Annoying as I just had to change a dozen passwords on devices just to support my new RP3. But oh well, problem solved and I'll know better in the future.

    That said, it would be nice in the future to see the WPA password character set standards being met :-)

    EDIT: Silly me, I was completely wrong about the reason why my password wasn't working. See my replies below :-) Cheers to @edmaul69 !

  • @Wizardling it also could be that the default keyboard on the pi is set to uk if you use something like the pound sign#. It is the british pound symbol instead. You have to change the keyboard layout. Not sure what symbols you were using.

  • @Wizardling Read this thread. Solution is in first posting. You don't need to reconfigure your network passwords.

  • @cyperghost Yep, it was the keyboard layout being set to en_GB. But setting the system to en-NZ instead (using RASPI-CONFIG's Internationalisation options) and rebooting hasn't switched my keyboard layout. Hmm..

    You know, the reason why my password wouldn't work was so easily tested (by typing it in plaintext somewhere else), but it just never occurred to me I'd buy a system in NZ set to an en_GB keyboard layout by default, heh. But of course the Pi is made in the UK, isn't it? Or at least designed there.

  • Quick google and I found how to change keyboard layouts :-)

    Anyway, I'd already changed all my passwords, and I suppose it can't hurt to avoid stumbling into another situation like this in the future, by sticking to alphanumeric network passwords. After all, it can and has been a pain entering symbols using the on-screen keyboards of some other lesser devices. So I'm avoiding that too, and all's well that ends well.

  • @Wizardling Also a gold choice to change password. Annother solution is to use the import feature .... But use the hashed PW value instead.

    Every hash consits of a HEX value. So it does not matter if you used special Characters.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.