Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Aimtrak Light gun and Mame2003



  • Tried again and now it works great. Bar was positioned incorrectly I think.



  • @HurricaneFan Do you know if it would work also as steering wheel for driving games?
    Dolphinbar manual mentions this function but no idea on how to activate it with advmame.


  • Global Moderator

    @UDb23

    Dolphinbar manual mentions this function

    I actually contacted the manufacturer about that claim and they said it was a feature that could only be used in Dolphin. However, it pretty clearly says in both the manual and website that it should be available as an alternative control method for for the USB HID controller mode. I also asked around on the Dolphin emu forums, as the device is widespread there, but no one knew anything about it. It would be great to use it as a steering wheel, or for other analog control schemes. The implementation of Stella on my hacked Wii makes use of the same idea for nuanced paddle control and it works extremely well.



  • @mediamogul I know that there is a steering wheel mount thing that you can put a Wiimote in, but I dont think that comes with pedals. Even if the steering wheel does work, you'd probably have to get a separate thing for the pedals, and i'm assuming that would be a nightmare to set up/configure. Would be super cool though...


  • Global Moderator

    @BGallagherLA

    I have a few of the official Wii Wheels. They're a surprising amount of fun.



  • @mediamogul Have you gotten them to work on RetroPie? Do you need pedals, or can you just map the Wiimote buttons as gas/brake?


  • Global Moderator

    @BGallagherLA

    I haven't tried it myself, although I'm pretty sure it won't work in conjunction with the DolphinBar unless that advertised sensor mode is somehow alluding us. However, if any of the linux Wiimote drivers pass the g-sensor information along as an analog controller axis, then it should work just fine.



  • @gunpadawan I'm getting this error when I try to install the setup.py script step:

    pi@retropie:~/gunconf $ python setup.py install
    Traceback (most recent call last):
      File "setup.py", line 1, in <module>
        from setuptools import setup, find_packages
    


  • @HurricaneFan sounds like you are missing setuptools
    try this:
    sudo apt install python-setuptools



  • @gunpadawan Now it's throwing this error:

    pi@retropie:~/gunconf $ python setup.py install
    running install
    error: can't create or remove files in install directory

    The following error occurred while trying to add or remove files in the
    installation directory:

    [Errno 13] Permission denied: '/usr/local/lib/python2.7/dist-packages/test-easy-install-1018.write-test'
    

    The installation directory you specified (via --install-dir, --prefix, or
    the distutils default setting) was:

    /usr/local/lib/python2.7/dist-packages/
    

    Perhaps your account does not have write access to this directory? If the
    installation directory is a system-owned directory, you may need to sign in
    as the administrator or "root" account. If you do not have administrative
    access to this machine, you may wish to choose a different installation
    directory, preferably one that is listed in your PYTHONPATH environment
    variable.

    For information on other options, you may wish to consult the
    documentation at:

    https://pythonhosted.org/setuptools/easy_install.html

    Please make the appropriate changes for your system and try again.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.