Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

retropie stuck



  • So I put Raspbian on my sd card boots fine. Then I ran the retropie script seemed to have run fine. I ran update to make sure everything was nice and proper. Then I logged out to cmd line and ran retropie by typing emulationstation. The splash screen pops up then disappears almost instantly and brings me back to a fresh cmd line screen in which I cant do anything. Anyone have any ideas on what the problem may be?

    Thanks ahead of time.


  • administrators

    When asking for help read and follow https://retropie.org.uk/forum/topic/3/read-this-first which is shown on signup, as well as bring at the top of the screen in bold. (I thought putting the message at the top of the screen in bold would encourage people to read it - but no.... I should have known)

    You should probably start with a premade image rather than installing on top of Raspbian. But I have no idea what system you are installing on, or how what install guide you followed, or what version of Raspbian you are running etc. Which splash screen ? The Emulation Station loading screen or the RetroPie boot splashscreen ?


  • administrators

    Assuming Emulation Station crashed - from an SSH connection please post the output of

    /opt/retropie/supplementary/emulationstation/emulationstation --debug
    

    Please format it in a code block - see http://commonmark.org/help/



  • I cant reply with the info for some reason it keeps saying marked as spam.


  • administrators

    post it on an external pastebin site and link to it



  • Sorry for not reading it. The first thing I did was search relevant issues. By doing that your sticky doesn't appear.

    pi 3b
    SD Image of Raspbian then ran the retropie script
    Just a keyboard and mouse
    Guide used: [link text](link url)
    How to replicate the problem: install retropie then reboot to cmd line and run emulationstation. I am running all of this directly on the pi3 b itself.

    Thanks


  • administrators

    @pi101 said in retropie stuck:

    Sorry for not reading it. The first thing I did was search relevant issues. By doing that your sticky doesn't appear.

    It is linked when registering on the forum - you have to agree to read it when registering. It is also at the top of every page in bold. So don't see how you missed it.

    I will need to see the output of the command above as mentioned - if you ssh in you can easily copy and paste it (Don't forget to format it in a code block as I asked - http://commonmark.org/help/)

    https://github.com/retropie/retropie-setup/wiki/ssh

    If you are unable to do this, then I recommend you use a pre-made image, as manual installations are more suited for those that are comfortable at the command prompt.



  • lvl2:   EmulationStation - v2.0.1a, built Oct 22 2016 - 21:35:15
    lvl2:   Creating surface...
    lvl2:   Created window successfully.
    lvl2:   Added unconfigured joystick Microsoft X-Box 360 pad (GUID: 030000005e0400008e02000014010000, instance ID: 0, device index: 0).
    lvl2:   Checking available OpenGL extensions...
    lvl2:    ARB_texture_non_power_of_two: MISSING
    lvl2:   Loading system config file /etc/emulationstation/es_systems.cfg...
    lvl1:   System "amstradcpc" has no games! Ignoring it.
    terminate called after throwing an instance of 'boost::filesystem::filesystem_error'
      what():  boost::filesystem::create_directory: Permission denied: "/home/pi/.emulationstation/gamelists/amstradcpc"
    Aborted
    

  • administrators

    somehow the gameslist folder has got the wrong permissions (and possibly others). Did you use a scraper or launch emulationstation as root or do any file management as root ? you will need to chown -R pi:pi /home/pi/.emulationstation/gamelists


  • administrators

    ok - it's a bug introduced recently by a change in retropiemenu. Fixing. (I see another reference to it on the forum). Would only affect fresh installs.



  • @BuZz
    Awseome. That worked! Thanks a bunch. I did not use a scraper and if I did it would be by mistake as I have no clue what that is. And I tried to launch it with sudo as I was trouble shooting this issue but upon doing so I received an error stating to not run emulationstation with sudo please try again. Something along those lines anyway.

    Appreciate the help.


  • administrators

    should be fixed now for new installs.


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.