Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Transfering files, images, splashscreens etc.



  • Hey Everyone,

    Might be a dumb question but here goes. What's the easiest ways to transfer files I need to my raspberry?

    I'm working with a raspberry Pi zero, that has no internet, so I need to to all my work through a usb. I want to transfer a new video splashscreen, images for games, themes and perhaps more.

    So what's the easiest way? If I insert my sd card in my computer I don't see the complete file system., is there a program I can use?

    Ps. Do I have to manually add artwork for all games or can I somehow make that process easier?



  • I recommend installing vsftpd on your Pi to setup a Secure FTP server to transfer files. Assuming you're running on Raspbian, just issue the cmd: sudo apt-get install vsftpd

    You can follow that portion of the guide here: https://github.com/retropie/retropie-setup/wiki/Transferring-Roms

    I recommend modifying the config after install before you conenct: sudo nano /etc/vsftpd.conf
    Set the following options:
    anonymous_enable=NO
    local_enable=YES
    write_enable=YES
    force_dot_files=YES

    Restart the service: sudo service vsftpd restart

    You should then have full access to the file system on the Pi.



  • Great! Thanks, I tried it out but I can't seem to transfer files, I get an error in Cyberduck saying that I do not have permission. What to do?



  • I missed where you said you have no internet! I'm a bonehead. Any chance you can get it on a network for initial setup? Sorry I don't know a USB method unless you load the files on a USB stick and transfer them directly on the Pi.

    However, if you can get it on the network you'll have to determine the IP. I would use SSH to remotely administer the Pi, but the first step is determining the IP. :)

    Are you able to connect to the Pi by SFTP and browse the file structure?



  • Hi!

    No problem, I managed to get internet access and ran the commands you suggested. I now can access the pi from my mac using Cyberduck and see all my files :)

    However! I can't transfer any files, I get error 550 saying that I can't transfer or remove files due to something about permission.

    Do I need to enable access to the pi or something? It's really frustrating, my folders are right there now but I can't transfer anything haha.

    Big thanks for your help.



  • @martinnoren the root user needs a password set and then you log in as root instead of pi to do certain stuff.
    https://github.com/retropie/RetroPie-Setup/wiki/FAQ#why-cant-i-ssh-as-root-anymore



  • Plus if you've got it on your network, you can just use the Samba shares to transfer files instead of a third-party client.



  • @edmaul69

    Thanks! I tried it but it didn't work, still getting the same error, not able to transfer files using cyberduck.

    @markyh444

    Samba Shares?





  • @markyh444

    Allas I'm working on mac, "if on windows" it says. So I assume it's only for windows.

    So the problem stands, not able to transfer files even though I have changed root password and edited the settings from the link @edmaul69 suggested.

    550 error, no permission. Cyberduck says.



  • Can you SSH to the Pi?

    I use Transmit to send my stuff over, but I can't see Cyberduck doing anything magically different even though it's free.



  • @obsidianspider

    I can see all files and folder structures on the pi using cyberduck in my case. I can not write anything to it though, can't transfer for instance to the splash screen folder.



  • @martinnoren What are the permissions on the folder?

    SSH in and run this

    stat -c %a splashscreens
    

    you should see

    755
    


  • So I connect to the pi from my computer, after that I run the lines you suggested on the pi?

    If I have understood you correct it's not working, I do not get 755, I get cannot:stat splash screens, no such directories.



  • How are you getting to the terminal on the Pi?

    However you do that, when you log in as pi you should be able to run

    ls
    

    and you should see

    RetroPie  RetroPie-Setup
    

    If you enter

    cd RetroPie
    

    then type in

    ls
    

    you should see

    BIOS  retropiemenu  roms  splashscreens
    

    Then you should be able to run

    stat -c %a splashscreens
    


  • Great!

    I now used F4 on the pi to get into the cmd, then inserted the lines you suggested. At the end I received 777 ... whatever that means.

    Whats my next step from here?



  • @martinnoren 777 means you can do everything to that directory, read, write, etc. Weird that you're unable to copy things to it. When the Pi is connected to the network, can you SSH to it from the Terminal?



  • So as I'm not doing anything stupid, my process again.

    I start up the pi, I have enabled ssh access on it, setting a new password and whatever else previous instructions from you guys has entailed.
    I go to my mac, into cyberduck, input the ip and user info, connect and I see all the folders.
    I try to copy a file from my desktop into splash screens, using cyberduck, I get the error.

    How do I SSH from my terminal?

    Again, super big thanks for your time!



  • @martinnoren open Terminal on your Mac. then type in ssh username@ipaddress where username is your username (usually pi) and ipaddress is the ip address of your pi. You'll then be prompted for your password, enter that, and then you should be able to do everything you could do when you pressed F4 with a keyboard plugged into the pi.



  • Cool, I'm in. What can I do with this? How does this enable me to solve the problem with transferring files?


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.