Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

usb controller converter for ps1 not working in ES



  • I'm essentially having this same problem: https://github.com/RetroPie/RetroPie-Setup/issues/1140

    Using RetroPie 4.xx with a B+

    We're running a PS1 controller through a converter to a USB plug.

    When I run the controller config from the menu it reads as usb joystick2 and I can assign all the correct buttons and they work while i'm looking though the emulators and games. However once I start a game, the controller doesn't work at all.

    I tried assigning the numbers the controller config said it was assigning to the retroarch config file for joypads, but that just messed up the mapping.

    When a ROM starts, it says it recognizes joypad 0 and joypad 1 but the controller doesn't work. I've tried switching the default joypad from 0-2 and that didn't work either.

    Any clues? Thanks!

    Picture of our setup: Click here



  • @plwiatt The Pi detects player 1 as joystick 0 and player 2 as joystick 1. Have you tried just plugging into the other port of the adapter? From what you're saying, it looks like you've got the ports mixed up and are plugged into the player 2 port.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.