Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

(Solved) Strange transfer rate (slow) over the network



  • Hello,

    I am new to retropie and I just completed my setup with pi3-B / retropie 4.1.

    Everything worked fine until I tried to transfer large files (~100MB) over the network - ethernet. Problem is that the transfer rate starts normally but then it suddenly drops to zero and goes back to normal after 5-20 seconds. I recorded this video for better visualization:

    https://drive.google.com/file/d/0B9763Hn4UiocRkNiVV9LNVRacnM/view?usp=sharing

    This keeps happening all the time and it makes transfering large files or large amount of files a pain in th a**.

    My other devices on my network are operating normally. I tried to restart all my network devices.

    Wifi is even worse, it keeps disconnecting and not reconnecting, even tough my wifi devices work normally in the same room.

    Any help is appreciated!

    Also, a noob question: How can I check how much space I have left in my sd card?



  • @gui_ i cant answer everything but if you quit emulationstation it shows you in terminal.



  • @gui_ said in Strange transfer rate (slow) over the network:

    Also, a noob question: How can I check how much space I have left in my sd card?

    df command is fine

    df
    df -h
    

    Google is also your friend
    http://www.tecmint.com/how-to-check-disk-space-in-linux/


  • administrators

    @gui_ sounds like your sdcard write speed is the bottleneck. It goes fast while data is cached in memory, but eventually it needs to be written. What sdcard do you have ?



  • Yep what @buzz said.....wondering about that SD card.
    By default the pi does not actually use all of a class 10 chip....from my testing it clocks in at around a class 4-6 without overclocking the sdram settings.
    For disk space I made a small toolkit to help but the toolkit is 100% dependant on the network.
    there is a script in there called Disk Space that will log into your pi and spit out the available space.
    I demo it here.



  • Hi guys,

    Thanks you all for your replies.

    The "strange" transfer rate was indeed caused by the sd card write speed. I had a class 4 and now switched to a class 10. The problem still persists but at much lesser and acceptable extent. Guess it is because the transfer rate over ethernet is still higher than the sd write speed.



  • @gui_ even with an SD card overclock (the only way to get the pi to actually read/write at class 10 speeds...the max I can upload a file at is around 2mbps....but normally floats between that and 1.5



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.