Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

  • Raspberry pi 3 - Retropie 4.1.5
    Runned "Update all installed packages".
    Joystick detected as "DragonRiseInc.GenericUSBJoystick", works well with emulationstation and Mame but on Amiga and Neogeo y-axis didn't work.

    Fixed it on Neogeo, changing
    JA_LR=3
    JA_UD=0
    to
    JA_LR_1=3
    JA_UD_1=0
    in /opt/retropie/configs/fba/fba2x.cfg

    Now y-axis is recognized but up and down are inverted.
    After many checks on config files I did the following test:
    run the "CONFIGURE INPUT" in emulationstation and swapped them, pressing 'down' when prompted for up and 'up' for down.
    After that, on emulationstation up and down are inverted, and I expected them to work well in Neogeo, but they don't, they are still inverted. there too
    Checked in /opt/retropie/configs/fba/retroarch.cfg and /opt/retropie/configs/neogeo/retroarch.cfg, there are no overrides so I think the current configuration is /opt/retropie/configs/all/retroarch.cfg which has
    input_player1_up_axis = +0
    input_player1_down_axis = -0

    • and - are correct, I checked with jstest /dev/input/js0
      but even swapping them doesn't fix it.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.