Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Dreamcast not showing up?



  • Raspberry Pi 3
    RetroPie 4.1.5
    No Overclock

    I've installed Reicast from the optional menu, added the correct BIOS and even threw in a game (although it was in multiple files with one ending in a .gdi), but Dreamcast does not show up in my menu at all. Went thru the video that is over a year old just to make sure I'm not missing anything, but the guy even says if systemManager.cdi (although the link says it is not found, to whereever it links to) is in the roms directory, then it should show up in your menu. Am I missing something? I'm sure this is how it's worked before.


  • administrators

    @Dominus Have you switched "Parse gamelists only" on in Emulation Station? (If so, switch it off).



  • Nope that is off.



  • I looked in the /etc/emulationstation/es_systems.cfgand Dreamcast was listed. I remembered there being another es_systems files somewhere, so I went to opt/retropie/configs/all/emulationstation/es_systems.cfg and there was no Dreamcast listed. I added it and now it works. I don't understand why it keeps using that one anyway? It's owned by root too, so I'm thinking when I installed Reicast it didn't edit that file because it couldn't save it.


  • administrators

    @Dominus /opt/retropie/configs/all/emulationstation/es_systems.cfg only exists if you copied it there - perhaps for a customisation - RetroPie does not put any es_systems.cfg in that folder.

    If you customise it there, it will never be touched, so it will be up to you to update it manually from the system one in /etc/emulationstation



  • So I can just delete it and I should be fine then?


  • administrators

    @Dominus Yes.



  • Hi, I'm very new to RetroPie and have run into the exact same problem with Reicast. Dominus, since you got it to work, could you explain step by step how you included Dreamcast in the es_systems.cfg file? I'm trying to familiarize myself with the raspberry pi's commands but don't know them all yet. Thanks for any help!



  • @Vincehor There might be 2 es_systems.cfg files on your system. Not sure if you have WinSCP, but get it, then navigate to /etc/emulationstation/es_systems.cfg and check to see if Dreamcast is listed in that file. Then go to opt/retropie/configs/all/emulationstation/es_systems.cfg and see if Dreamcast is in that one. For some reason just delete that one... I'm not sure how it got there on mine, and perhaps the same happened to you?



  • @Dominus thanks for replying. I checked /etc/emulationstation/es_systems.cfg and dreamcast is listed. But I checked and there is no opt/retropie/configs/all/emulationstation/es_systems.cfgfile. Still don't know why Dreamcast isn't showing up with Reicast installed. Any thoughts?



  • @Vincehor Did you install it in the experimental menu, and put roms in the folder (although in this case I don't think it needs roms to show up).



  • @Dominus No, I installed it from the optional installs menu. And I did put roms in it, but the Dreamcast menu didn't show up.



  • Yeah that's weird. It should be showing up, unless there is another es_systems.cfg file it is loading first. I'm not sure how mine got where it was, but I deleted it, and a wack of new emulators I had installed showed up, as it started reading & loading the correct es_systems.cfg file



  • @Dominus Turns out I was being stupid. The es_systems.cfg file in the /etc/emulationstation/ directory actually did have the Dreamcast coding in there, but I didn't scroll down far enough to see it. Ugh! But I then copied the file to the /home/pi/.emulationstation/ directory and it now showed up in the Emulation Station menu. Thanks so much for your help!



  • Wow, I have been struggling forever to figure out what was going on with this issue! I was pretty sure I was doing everything right, but then I stumbled in here, and sure enough, I have the 2 cfg file issue too!

    Since it's been quite a while since this post was last active, I chose to copy the entry to
    /opt/retropie/configs/all/emulationstation/es_systems.cfg, rather than delete the apparently-redundant one, as who knows what's changed since then! :)

    <system>
      <name>dreamcast</name>
      <fullname>Dreamcast</fullname>
      <path>/home/pi/RetroPie/roms/dreamcast</path>
      <extension>.cdi .chd .cue .gdi .sh .zip .CDI .CHD .CUE .GDI .SH .ZIP</extension>
      <command>/opt/retropie/supplementary/runcommand/runcommand.sh 0 _SYS_ dreamcast %ROM%</command>
      <platform>dreamcast</platform>
      <theme>dreamcast</theme>
    </system>
    

    Incidentally, a lot has certainly changed on the hardware side too. If you've got a RPi4, install the Flycast core instead of Reicast. Holy moly it's so very close to the original experience now!

    Thanks to all involved for bringing up and solving this issue; I can finally play around with some of these games instead of tweaking settings endlessly now!



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.