Please do not post a support request without first reading and following the advice in

  • First of all, apologies as I realize versions of this question have been asked before. I can't seem to find a suitable answer for my particular situation, though. As a Pi noob, I'll try to be as specific as I can to minimize annoyance.

    I got a CanaKit starter kit with a R-Pi 3 Model B and a 5V power supply.

    Downloaded the RetroPie install image for R-Pi 2/3 from

    Followed the installation instructions from
    exactly, as far as I can tell.

    Initially it ran fine; I'm able to configure my Speedlink Torid gamepad to work with the GUI to check settings

    My issue is that after configuring WiFi, installing a couple ports (KODI and Giana Sisters), transferring ROMs via USB, and generally looking around at the menus, I inevitably end up at the command prompt. Don't ask me how, as it's happened to me a couple different ways (because I've reformatted and reinstalled the image 3 times now, you see.) When I've rebooted, it stays on the command prompt as well.

    First, I don't get what is causing this. Should the configuration on the SD card, which seems to work properly on initial startup, not reboot to the GUI? I don't perceive that I've changed any boot settings. Second, when I type "emulationstation" to restart the emulator, it pauses for a couple seconds and just returns to the command prompt.

    How do I fix this issue? Alternately, assuming I'm stuck with the command line, which directory do I go into and what do I run (and which command do I type) to manually load Emulation Station?

  • @Pi-Zarro Have you tried updating all installed packages thu retropie setup script ?
    check here

  • @UDb23 I tried that once, but after a long while (although I'm not too familiar with Linux) it seemed to me like it was choking on installing the kernel. That was one of the times I just unplugged and reformatted. Is it feasible to have this process take an hour or more?

    I'm using a 32 gb SD card, btw. Plenty of space...

  • @Pi-Zarro it takes about half an hour on a Pi3; of course depends also on how many emulators you have installed. Still think it's worth trying.

  • Hey, thanks for the suggestion. Earlier today I updated the packages minus the kernel -- took all of 10 minutes. Reconfigured to boot into ES, and that seems to have taken care of the booting-to-command-prompt issue.

    Unfortunately now I have another issue I've been wrestling with all day. ES / RetroArch isn't automatically generating a systems list based on the ROMs I've installed. They're on the card for sure, as I see the "roms" folder in the //RETROPIE shared network folder via my Windows PC. I'm guessing it doesn't belong there? Any ideas?

  • @Pi-Zarro ROMs should be in the system specific subfolder of the ROM folder.
    It is very strange ES not recognizing the roms you place. I have no clue what it could be. Do you have another micro SD to install Retropie on it from scratch ? It could be an SD issue.

  • administrators

    @UDb23 parse gamelists only is switched on in es? Need more info. Example filename and paths etc

  • @BuZz @Pi-Zarro has the issue.

  • administrators

    @UDb23 yep sorry. I meant that for op.

  • Sincere thanks, guys. I finally got it to work last night by installing a completely different build (Steve Smith's triple-boot at Still not sure what happened, as this setup just worked smoothly, ROMs transfer just fine, etc. THEN I had to learn about the wonders of HDMI sound being flaky on RPi, and adjusting the config file to activate it. Interestingly, it didn't work plugged directly into my small TV, but it works fine plugged through the receiver connected to my big TV.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.