Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Video Splash Screen Not Working Right



  • So, I'm trying to make a video splash screen for retropie. I checked some guides online and did everything they said (as far as I know) and it seemes to work for a little bit, then goes screwy and dumps me at the main menu.

    So, I uploaded a video since it was hard me to articulate what exactly the problem was. I read that oxmplayer (what runs the video I think? Not sure) would override the EmulationStation screen if I played a long enough video so I made it a generous 40 seconds.

    It plays fine until it reaches what I assume to be when it shifts to the emulation station loading screen and goes bananas.

    I would love any help since I am a very nooby beginner with this. I followed this guide: http://blog.sheasilverman.com/2013/09/adding-a-startup-movie-to-your-raspberry-pi/

    and think I did it correctly, though I can't be sure. I got no errors when I was doing it and no crashing or anything.

    For reference, I had already made the video and had it running as it is now before following that guide, but I assumed I did something wrong and following that guide didn't "help" if it makes sense.

    And please if you do respond speak to me like an idiot about this since I could use a step by step hand holding if it were possible, honestly. thanks again.



  • @NecroCorey try the following -

    1. Use an ssh session or keyboard do the following on your Pi:

    2. edit the autostart script

    nano /opt/retropie/configs/all/autostart.sh
    
    1. insert this line before the emulationstation line
    while pgrep omxplayer >/dev/null; do sleep 1; done
    
    1. save the file and exit (in nano, it's control-O and then control-X)

    This addition will prevent emulationstation from starting until omxplayer is done with the video.



  • @synack Ok just to be sure, that means open it with putty then copy paste the first thing to get me into settings, and then find the line for ES and add that before it yes? Sorry like I said super nooby.

    EDIT: Ok I went and tried it and it DID FIX THE GLITCH but I still see the ES screen before the main menu. Is there a step I'm missing so that it plays the video and goes right into the main game selection menu? I thought this was how I did that.



  • @NecroCorey Yup, you've got it.



  • @NecroCorey As far as I am aware, there is no way to do that as it'd require a change to the source code.



  • @synack Ok thanks a ton you were crazy helpful. I must have misunderstood one of those guides I read. I thought if I played a long enough video it would go right to the main menu.

    If there's a way to mark this 'solved' I don't know how to do it but this is super solved.



  • @NecroCorey I believe that behavior (playing the video while the ES system loads) does work with some people's setups, but not all -- including my own. I'm not exactly sure of the details there.

    My suggestion was mainly to address the issue you were having with the "screen going screwy" :-)


  • administrators

    @synack I think another solution was to remove the layer setting (-b 10000 part)from the OMX call but is been a while since I've messed with it. There's probably a reference to it somewhere else on the forum



  • @synack hi, I had the same problem as well and tried this and it worked but will not boot into emulation station after. After the word "done" is there just a space or should there be something else?



  • nevermind, I got it. Had to make emulation station on the 2nd line



  • Sorry to bumb the topic, but I followed the instructions and what it does now, is that it won't start the EmulationStation automatically. After the video, it just shows the command console after logging in and I have to manully start the ES everytime.

    Edit: It was not specified in the second post, that do I need to put those commands into different lines or do I have to keep them on the same line, but put the new one before the ES one ?



  • @dd-indeed Add an & symbol. like this.

    sudo nano /opt/retropie/configs/all/autostart.sh

    while pgrep omxplayer >/dev/null;
    do sleep 1;
    done &
    emulationstation #auto

    ctrl+ x

    Y

    enter

    sudo reboot now



  • i am also having the same issue.

    im on emulation station v2.6.3RP
    retropie set up script 4.2.22

    i placed the files within the retropie folder/ splashscreen / comicbook splash using cyberduck (the same way i place everything else and no other issues)

    and activating via retropie -> splashscreens -> own/extra -> select comicbook splash.

    here a youtube link to the issue in action

    sorry about the air conditioner, and audio



  • Instead of adding "&", add ";" as in:

    while pgrep omxplayer >/dev/null; do sleep 1; done;
    emulationstation #auto

    This worked for me.



  • @skoufix Thanks, the fixes above did not work for me but yours did. I'm glad to finally get rid of the startup glitch.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.