Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Video Splash Screen Not Working Right



  • @synack Ok thanks a ton you were crazy helpful. I must have misunderstood one of those guides I read. I thought if I played a long enough video it would go right to the main menu.

    If there's a way to mark this 'solved' I don't know how to do it but this is super solved.



  • @NecroCorey I believe that behavior (playing the video while the ES system loads) does work with some people's setups, but not all -- including my own. I'm not exactly sure of the details there.

    My suggestion was mainly to address the issue you were having with the "screen going screwy" :-)


  • administrators

    @synack I think another solution was to remove the layer setting (-b 10000 part)from the OMX call but is been a while since I've messed with it. There's probably a reference to it somewhere else on the forum



  • @synack hi, I had the same problem as well and tried this and it worked but will not boot into emulation station after. After the word "done" is there just a space or should there be something else?



  • nevermind, I got it. Had to make emulation station on the 2nd line



  • Sorry to bumb the topic, but I followed the instructions and what it does now, is that it won't start the EmulationStation automatically. After the video, it just shows the command console after logging in and I have to manully start the ES everytime.

    Edit: It was not specified in the second post, that do I need to put those commands into different lines or do I have to keep them on the same line, but put the new one before the ES one ?



  • @dd-indeed Add an & symbol. like this.

    sudo nano /opt/retropie/configs/all/autostart.sh

    while pgrep omxplayer >/dev/null;
    do sleep 1;
    done &
    emulationstation #auto

    ctrl+ x

    Y

    enter

    sudo reboot now



  • i am also having the same issue.

    im on emulation station v2.6.3RP
    retropie set up script 4.2.22

    i placed the files within the retropie folder/ splashscreen / comicbook splash using cyberduck (the same way i place everything else and no other issues)

    and activating via retropie -> splashscreens -> own/extra -> select comicbook splash.

    here a youtube link to the issue in action

    sorry about the air conditioner, and audio



  • Instead of adding "&", add ";" as in:

    while pgrep omxplayer >/dev/null; do sleep 1; done;
    emulationstation #auto

    This worked for me.



  • @skoufix Thanks, the fixes above did not work for me but yours did. I'm glad to finally get rid of the startup glitch.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.