Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Controller works in retropie, but not in games?



  • My problem is that my ps3 bluetooth is coneected perfectly, and works fine in emulationstation menus and so on. But NOT in the emulator/games itself , there is a yellow message that said ps3 controller not configured. Then when i open retroarch from the retropie menu , i can use my keyboard to navigate up and down , but i cannot enter any menus in the retroarch menu. When press a s z x or all other buttons nothing happens, when hit enter it exits retroarch and returns to retropie menu ? How to get into retroarch settings ??



  • No one know the answer to this? Its bummer i cant play :-\



  • Hi Vartaz,
    I still have problems. But through USB connection it works fine, as I mentioned.
    Did you check this out?



  • I am seeing the say behavior running retropie on Ubuntu 16.04 LTS. My controller connects over bluetooth and works in emulationstation, but when I try to load a game I get nothing. The keyboard seems to work though.



  • If you can't enter any menus anymore you might want to reset your input settings.
    In emulationstation press F4 to quit emulationstation. In the terminal type:
    sudo RetroPie-Setup/retropie_setup.sh

    Navigate to: Manage packages -> Manage core packages -> emulationstation -> Configuration -> and run Clear/Reset Emulation Station input configuration.

    Leave the setup and type emulationstation to get back into emulationstation. I think it should ask you to configure the keyboard again. ( fingers crossed ;) )

    Now first configure input for your keyboard, then connect the ps3 controllers with bluetooth and configure their input as well. (Press the button you mapped for 'start' in emulation station and choose configure input).

    Then, if you run a game while connected with bluetooth and there still is no response, then perhaps you should take a look at this.

    Maybe following those steps will help you.



  • I'm running a Pi 3 with version 4.1 and a PS3 controller bluetoothed to it also. Inside emulationstation the controller works fine, but not in any emulators. It does work in Kodi. I have cleared the input setting and set retroarch to use the PS3 controller as default, but I still get no response inside the game emulators.



  • I suppose you all have installed the PS3 controller driver?



  • I had same problems.
    Complete reinstall (image) and did't do any updates worked for me
    Only installed PS3 driver from Retropie_setup.sh and all started working.



  • I'm new to retropie and had the same issues as described - using a PS4 controller (tried wired/ hardwired) - I could operate the menus with the controllers but not the Stella / Atari2600 emulator (and others) - tried everything suggested and nothing worked until I came across the following video where by the guy tells you to BIND Input Users1 via Retro Arch config then save it - the controllers then worked fine!!!! He shows how to set the HOTKEYs via Binding too - PERFECT!

    see around 08:26 mark



  • @speedbird747 tried both options still no luck.


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.