Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Where is Darkplaces?


  • administrators

    was an error in the module variables. now fixed if you update (should be in optional).



  • Thank :) Yes, i updated the retropie-setup script, and now i see the Darkplaces package. I have installed it, but it doesn't show up in te "Ports" menu in emulationstation.

    .... i suspect that i should update something more than just the retropie-setup script?


  • administrators

    @Xyb0t I will look into it - could be related to some recent changes.


  • administrators

    @BuZz that or he failed to refresh emulationstation


  • administrators

    there was a dependency issue which could have been a problem if no other quake versions were installed. Please update retropie-setup and try again (confirmed working here now after the update).



  • @BuZz Thank you so bloody very much!!!! It works perfectly now!

    I updated the retropie-setup again, then rebuilt Darkplaces from binary, rebooted the Pi, and there it is :D (the rebuild took a little longer than the installation did the first time around... i guess it figures?!)

    Holy cow, It looks fantastic! So much better than tyrquake :) A little choppy at certain places (i bet it's due to the dynamic lighting and stuff), but i guess a little tweaking in the gfx settings will make it hit an acceptable balance between beauty and raw fps, hehe...

    Thank yo so much for looking into this issue! ...so, these fixes will make their way into the next RetroPie release?


  • administrators

    @Xyb0t it I agree it looks nice.

    The dependency fix will be in the next pre-made image, although darkplaces itself is not included by default.



  • This morning i figured i'd look into the low framerate, and i see that the resolution is set to 1920x1080, which may be a little harsh even for the Pi3 :)

    To adjust resolution, i have to toggle fullscreen to "off", and then i am allowed to shift the screen resolution. But it only affects the overlay (menu/console). Hmm, well i exit Darkplaces and run it again only to discover that the resolution is back to 1920x1080 in the settings (settings like fullscreen, crosshair, show fps and so on is saved though.. only resolution is 'reset').

    I exit Darkplaces and opens the file "configs/ports/quakedarkplaces/id1/config.cfg". I try to type in the resolution manually (i figured that 960x540 was worth a shot), and then run Darkplaces again. The result of this was that resolution stayed at 1920x1080, and checking the file once more, my manually typed values were overwritten.

    I tried a few other resolutions, but the outcome is the same :( Can anybody advise me how to set the in-game resolution, or make it work as expected?


  • administrators

    @Xyb0t change video mode in run command menu?



  • Bingo :) Thanks!!

    Facepalm @ self for overloking that option... well, now all is good.

    Perfect!


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.