Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

SAMBA under Mac 3.7 stopped working



  • The first few days on 3.7 it was fine, did a script and binary update and it stopped working.

    Any suggestions?

    Luck I did a backup just after going to 3.7 when it was working still so i'm sticking with that for now


  • Global Moderator

    I can confirm that just a bit after 3.7, I too ran a script and binary update, only to find SMB non-funtional.



  • Well thats something I was wondering it can't just be me. Are you on Mac or PC?

    If on Mac it's not an OS problem I have tried from a 10.9/10.10 and 10.11 machine they all do the same.

    What I did do today was again role back to my backup image of 3.7 just after it comes out, it all worked fine again.

    I didn't do the script and binary update, but I did quit out and did a sudo apt-get update and upgrade and this seems to kill the samba.

    So I'm I'm still not sure how to fix it. but this maybe give someone a clue to help us


  • Global Moderator

    I run three Macs, one Win PC and two Linux PCs. The three Macs all lost SMB access to RetroPie at the same time. All the other systems can connect as usual.



  • @mediamogul Interesting, I guess most people maybe using PCs so thats why maybe not many people have noticed.


  • Global Moderator

    @raymate

    I've gathered a few possible leads to the cause of this problem and am going to take a stab at solving it later this evening. I'll let you know if anything pans out. In the meantime, if anyone has any experience in this area, your input would be most welcome.


  • Global Moderator

    i'm on a mac (latest osx) and can confirm samba doesn't work for me either.

    only leads i have are:
    https://github.com/raspberrypi/linux/issues/1278
    https://github.com/RPi-Distro/repo/issues/19
    both closed as logged in the wrong place.

    maybe it's logged against raspian, but can't find anything.


  • Global Moderator

    @dankcushions

    Thanks DC, that info really helped me in throwing some extra spaghetti against the wall. Unfortunately, nothing stuck. I tried quite a few things, showing only minimal results. The best I got was OSX timing out rather than failing outright. It looks as though this will have to be worked out upstream by the Raspbian team, although I would love to be proven wrong here.

    The Raspbian team might not even see this as being worth their time. OSX's implementation of SMB has been cagey ever since Lion. There are a few conspiracy theories, but all that is truly known is that for some reason, Apple decided to write their own version of SMB starting with 10.7 and their attempt had all the problems you might expect in a first effort. That would have been fine as growing pains are always to be expected in situations like this. However, Apple never bothered to go back and straighten out any of the problems, leaving it a complete mess since I believe 2008.

    For those who might be affected by this, there are still a few good options to consider. First, in my mind, SFTP is probably a better solution to begin with. Then there is always the option of adding the "pi" user credential to RetroPie's SMB list of approved users, allowing the finder to connect using a chosen password. However, keep in mind that if you leave the Finder out of the equation all together, you'll avoid all those unsightly Mac-specific files that tend to litter up a drive. These files are invisible during Mac use, but are fully visible and can become quite annoying on any other system.



  • Just an update to anyone who may still be struggling with this..

    The issue is to do with an update that has been pushed out to samba to deal with the 'badlock' vulnerability. I can't remember the precise details of it but essentially it had a knock on effect with passwordless shares and old legacy sharing (e.g. time capsule).

    To circumvent this you can just use the 'pi' user to access the shares but you will not be able to do this from the off. You need to run the following command from the terminal:

    smbpasswd -a pi

    Then enter a password for the smb user. I've just used the same password for consistency.

    Once that's done just try to access the shares again and use the username / password combination from above. :)



  • I am still having problems. I am also new to Pi. I setup with the latest setup today. But when I try to share from my MAC to the retropie, my MAC sees the retropie, but it asks me to sign in. The username "pi" and password "raspberry" is not working. I went to terminal on my MAC and typed the above command, but that did not help. Can you give me more detail on the steps? Thanks...


  • Global Moderator

    @bworkman said in SAMBA under Mac 3.7 stopped working:

    I went to terminal on my MAC and typed the above command, but that did not help.

    Did you connect to the Pi first via SSH before you ran that command?


  • Global Moderator

    This may have been mentioned elsewhere, but for anyone affected by this issue, it seems to have been fixed as of this posting and a work around is no longer needed. Confirmation and issue closure specific to RetoPie can be found here.


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.