Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Over- and underscan (Quake 1/3 screen too big)



  • Running Rpi 4.1 on Pi3 with official 2.5A PSU, using 55" full HD TV 1920x1080

    So, my TV has black bars consistently, both at startup, splashscreen, ES screen and ES menu. Even inside 'normal' emus. If i go to the config.txt and compensate using 'disable_overscan' or/and 'overscan_scale', the black bars will dissapear and i have a very nice screen...

    ..... except when running Ports (Quake and Quake3) the screen will be fullscreen, but it is cropped :( I looked in the Ports setting/config fro both these games, but i didn't find anything useful. If i disable overscan in config.txt again, i will see full Q/Q3 screen, but with the black bars again. Setting resolutions manually in Q/Q3 run-menus doesn't seem to affect the problem.

    So, is there any other method to circumvent underscan other than config.txt? Or could i sorta set Q/Q3 scaling manually while having the overscan compensation turned on in the config.txt, so the global settings won't apply to the Ports category?



  • @Xyb0t
    I'm not sure if you have the same issue but when I bring my RPi3 over to my mom's house and plug it into her TV, I get those black bars you mentioned but on my TV at home , everything is fine. One thing I tried was running Quake at a different resolution and it seamed to get rid of the black bars (or at least minimize them). I might of had to try a couple before it worked and I can't remember which one worked.

    Also I wonder if there is some settings on the TV that might need to be changed like:

    • If your TV has Game Mode then turn that on!
    • Disable any power saving settings or ambient screen dimming.
    • Turn off all post-processing effects on your TV like dynamic contrast, etc.
    • Make sure you're not daisy chaining the HDMI through an Xbox or another device (sometimes even amplifiers can delay signals).
    • Also test with each HDMI port in the back of the TV (sometimes the 1st or 2nd HDMI ports are faster than the rest).


  • Thanks for your input, but 'm pretty sure that this is something related to settings. This is because i can have my TV show the screen both with, and without the bars depending on the settings in te config.txt file.

    If it was a TV issue, i bet i wouldn't be able to get the full screen, even with the settings set to compensate for the underscan.

    To recap: It looks fine in all emus, menus, splashscreen and everything. The only problem is the Ports (i tested with Q and Q3)



  • @Xyb0t

    The only problem is the Ports (i tested with Q and Q3)

    I'd still recommend experimenting with changing resolutions for Q and Q3 from their respective settings menu.

    Also the the reason I suggested the additional settings for the TV was in hopes that you wouldn't need to use any overscan settings in config.txt ;-)



  • @Xyb0t
    Here's the short documentation about TVs to "prevent any overhead due to upscaling":
    https://github.com/retropie/retropie-setup/wiki/Speed-Issues#tv



  • Game mode seems to deal with smoothing and can create lag. Luckily i have no issues with that.

    As i stated in my initial post, changing the resolution in Q and Q3 doesn't do much, since the screen is scaled to 1080p afterwards anyways. The picture stays the same size (which is perfect size when i turn on overscan compensation, but turning it off gives me black bars).

    The non-technical description of my experience would be something like this: It's like the Quakes are perfect for my TV, but all the rest of the Pi gives me black bars... If i turn off the black bars, the screen 'grows', also the Quakes, but then they're too big despite the rest of the Pi fitting perfectly.

    Anyways, thanks for your input. I'll experiment some more this afternoon.



  • I've been investigating some more, and i am fairly sure that i'm correct in stating that Quake and Quake3 dos not have scaling settings in the runmenu.

    So, everything on the Pi runs beautifully fullscreen BUT Quake and Quake3 screen is bigger than the rest of the stuff, which makes it go beyond the edges of my TV.

    In Quake3 it's not really obvious besides the screen after the level is finished. But in Quake, the lower half of the statusbar is beyond the screen.

    • Setting various screen resolutions does not affect the issue
    • Settings on the TV does not affect the issue
    • I can have perfect Q/Q3 screens if i turn off oversca_scaling and overscan compensation in the config-file for RetroPie, but then EVERYTHING else will have black bars.

    So, is there any way that i can turn on compensation as per emulator? That way i can disable it globally (having nice Q/Q3), and then just compensate for everything else manually?



  • I should add that for Quake, i use Darkplaces. For Quake3 i think there is only 1 program. At least, i use the deafult one :)



  • Seriously? No replies at all??

    Is this because i amway off? Or is it that no one confirmed the same effect? Or maybe i am just the only one to discover this? :)

    It really is a pita for me, since i love fullscreen, and i love both retro emus and ports :S



  • @Xyb0t

    So, is there any way that i can turn on compensation as per emulator? That way i can disable it globally (having nice Q/Q3), and then just compensate for everything else manually?

    The only thing I can think of is to use the runcommand-onstart.sh and runcommand-onend.sh scripts:
    https://github.com/retropie/retropie-setup/wiki/runcommand#runcommand-onstart-and-runcommand-onend-scripts

    I'm not advanced enough in script programming to tell you want to actually put in those files :(

    In /opt/retropie/configs/all/runcommand-onstart.sh you might put something like:

    # if you're launching quake then change the overscan settings
    if [ "$1" = "quake" ]
        ??? some code here to change the overscan ???
    fi
    

    And in /opt/retropie/configs/all/runcommand-onend.sh:

    # if you're exiting quake then change the overscan settings back
    if [ "$1" = "quake" ]
        ??? some more code to change the overscan back ???
    fi
    


  • @backstander
    This sounds VERY promising :) I was not aware that these scripts existed (i'm still fairly new to RetroPie).

    So, Would anyone know if i can stuff these scripts with the ordinary parameters also found in the config.txt file and such?



  • @Xyb0t if you want it to work fine on everything without special code, in the config.txt leave it to the setting where you have the bars. Now at the top you see the up down left and right overscan settings. Remove the hashtags (#) and play with the numbers until you get it full screen. Then everything will work correctly.



  • @edmaul69
    Holy moly.. this actually did the trick!!!! Thanks so much for helping me out, man!



  • @Xyb0t glad you got it working good now.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.