Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Can you swap the stereo channels?



  • Searched for this but didn't have any luck...

    I built a bar top arcade unit, and got speakers wired in with what I thought was the correct placement, but when playing games that have stereo content I realized the channels are swapped. Is there anywhere in the software where you can specify to swap the stereo channels? Thanks.



  • @pedrohead
    I just tried this out and it worked for me. Raspbian/RetroPie uses ALSA for audio.

    This file probably doesn't existed so you'll need to make it & put this in the file:

    sudo nano /etc/asound.conf

    pcm.swapped {
        type         route
        slave.pcm    "cards.pcm.default"
        ttable.0.1   1
        ttable.1.0   1
    }
    
    pcm.default      pcm.swapped
    

    Source:
    http://superuser.com/questions/59481/how-to-swap-stereo-channels-in-ubuntu



  • @backstander

    awesome! i'll give that a try. thanks.



  • @backstander

    hey where did you put this file in the menu structure. is this /etc/ folder under the "/retropie" folder?



  • Personally, i'd rewire the spakers and it will be fixed permanently.

    With a config, you will need to do it every time you install a newer version of RetroPie or something like that :)



  • @Xyb0t Yeah, that could be true... I was just sick of taking this arcade deal apart now that I had it together and didn't want to do it :)

    But what backstander suggested ended up working.

    I was trying to type the script in wordpad and send it over to the Pi with WinSCP, but that was giving me some access error (maybe to do with being too deep in the root menus), but plugging in the USB keyboard to the Pi and typing as he detailed seemed to work.

    And I'm totally unfamiliar with Linux, but I could never get a double quote (" ") to appear when I typed out the script. That same key gave me an @ symbol instead... but I could get single quotes (' ') and that seemed to still work.

    Thanks guys.



  • @pedrohead

    hey where did you put this file in the menu structure. is this /etc/ folder under the "/retropie" folder?

    No, it should be under /etc/

    From the command prompt you should be able to just type sudo nano /etc/asound.conf
    This will load up the text editor called "Nano" and you can put that "code" in there and press Ctrl+O to save and Ctrl+X to exit

    If you're trying to browse to it over your network, it won't work because that directory isn't shared and if it was you won't have "root" permissions to write a file to it.

    Just SSH in (as long as your RPi is on your network)
    https://github.com/retropie/retropie-setup/wiki/ssh

    Or you can plug in a USB keyboard and press F4 to exit EmulationStation and you will be sitting at the command prompt.

    update
    Looks like you got it working :)



  • @backstander

    yep, got it working by doing just what you said.

    was a little curious about the quotes character in Linux though... the text from the script you provided showed that, but my keyboard only output a "@" character instead. but for whatever reason, single quotes worked on that line and the channels reversed from what i can tell.

    is that a linux thing that i don't understand yet? thanks again for the help.


  • Banned

    @pedrohead You have your keyboard set to a US layout if you are pressing SHIFT + 2 and getting the @ sign rather than quote marks " This can easily be changed.



  • @AlexMurphy This isn't from me pushing "shift + 2", but from me pushing the usual "double quotes/single quotes" button to the direct left of the "enter" key.

    Whenever I push that in the scripts when I'm in the pi, it produces a @ character instead of a " character. Is that a keyboard setting that I'm not privy to in Linux? Thx.


  • Banned

    @pedrohead I have no idea what key you mean. What sort of keyboard are you using?



  • @pedrohead
    I'm not sitting at my RPi but in EmulationStation if you go into the RetroPie menu and pick "raspi-config". Then in the "Internationalisation Options" there's an option to setup your keyboard (don't remember what it's called). It defaults to a UK keyboard but you can change it to a US or what every country you are in.

    Or you can type sudo dpkg-reconfigure locales from the command prompt which runs the same thing.
    http://rohankapoor.com/2012/04/americanizing-the-raspberry-pi/



  • @AlexMurphy

    Weird... maybe it's something unique to me.

    I have a plain old Dell USB keyboard that came with my PC. When I plug it into the Pi and type with it to create or modify a file (as done above), when I'm in that Linux nano text editor, and I push "shift + (the "/' key to the left of the enter key)", I don't get a " character out, I get a @ character. Oddly enough, if I don't push shift and push the "/' key, I do get the single quote ' character.



  • @backstander maybe that's it... i'll have to try that.

    curious (but glad) that the script you showed actually worked with single quotes (instead of double quotes), because i couldn't figure out how to get a double quote character out of the keyboard for the life of me :)



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.