Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Wiimote Driver Issue



  • So I'm using a wiimote that I setup per the wiki using the wminput method and starting the script to run it at boot, Works fine minus no joystick support only d-pad.

    I then came across some info on here about the hid-wiimote driver being buggy and causing some issues in the 3.6y? Kernel?(Unsure) I am an intermediate user of linux so I tried to build my own version from the github repo with no luck.

    Basically what's happening aside from no joysticks in emulationstation config is that pifba has the d pad inverted! Up is down etc. Left and right are fine. I tried to tweak this in the config for pifba but no luck. I also noticed this happens using this in the menus of an emulator/any of the places it has the old style gui(Unsure what to call the dos looking menus).

    Please help me correct this guys or point me to the documentation to fix it and learn more. It should probably also be stated that I'm using the classic controller only and just not using any of the regular wiimote portion. Thanks in Advance!

    Edited to say that I'm using the latest retropie build as of a week ago and a Retropie 3 b+.



  • Bumping for visibility. 140 views and no help?



  • I really hate to keep bumping my own post but has no one run into this issue or can help me troubleshoot it? Also thanks to whoever negged my rep on here. Real helpful. Instead of trying to help you just downvote and move on. =/



  • Not sure if this helps, but this link will take you to a script that will install the xwiimote and xwiimote-tools packages.

    Once installed you should be able to connect and configure the wiimote using the instructions here.

    Hope this helps!



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.