Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

AdvMAME losing mappings



  • I'm having an issue with getting my input mappings to stick in AdvMAME. I have 6 gamepads attached to the RetroPie; 3 USB, 3 Bluetooth. Gamepads 1-4 work just fine, but aside from the "Start" Buttons for 5 and 6, none of the other mappings will persist past a restart. I'm using RetroPie 4.1 on a Pi3. I just updated all installed packages earlier today (2/14/17). This is for AdvMAME 1.4.



  • A secondary question would be, where are the key mappings stored. I found a .rc file that appeared to contain them, but altering it didn't have an effect on the mappings when I restarted the game.



  • No suggestions? I tried the location for the mappings file mentioned in the wiki, but no file exists there. Does anyone know where the key mappings file for AdvMAME is?



  • @tribunal88 I use advancemame 1.4 and make edits in /opt/retropie/configs/mame-advmame/advmame-1.4.rc with success. You can also hit TAB using a keyboard while playing a game and set your inputs using the GUI. It will update the .rc file when you exit the emulator. If you make game edits for THIS GAME ONLY, the changes will appear in the file preceded with romname/ which can be handy for per-ROM configs.



  • @caver01 said in AdvMAME losing mappings:

    @tribunal88 I use advancemame 1.4 and make edits in /opt/retropie/configs/mame-advmame/advmame-1.4.rc with success. You can also hit TAB using a keyboard while playing a game and set your inputs using the GUI. It will update the .rc file when you exit the emulator. If you make game edits for THIS GAME ONLY, the changes will appear in the file preceded with romname/ which can be handy for per-ROM configs.

    This is indeed the method I use. Nonetheless, the changes for the 5th and 6th player aren't persisting past a restart of the ROM. I make all the changes to the controls (using the tab method you described and modifying "for this game"). The controls work as expected while the game is running. Upon exit, this file shows as being written as the timestamp is updated, however none of my changes are present when I edit the file. When I run the game again, the configuration is back to what it was before (except for "P5 start" and "P6 start", which do persist).



  • @tribunal88 it almost sounds like the file is read-only. Really strange. So, you never see the mapping entries in the file after you exit? What if you manually edit the file with changes and THEN launch?

    <edit> I re-read the above, and you DO see the start and select mapping. Still, it is odd that the others are not persisting.



  • @tribunal88 I am a little curious what the GUI displays when you map a control to one of your player 5 and 6 controllers. My experience is with keyboard controllers, so we are already beyond what I have done with AdvMAME. I also setup my config to run the keyboard as RAW input, so all controllers are the same. I wonder if @andrewsi has any thoughts. . .



  • I tried manually editing /opt/retropie/configs/mame-advmame/advmame-1.4.rc without any luck. I added entries for coin5 both specific to the rom and in general, and neither showed up when I booted into the game. I did manually alter the values for coin1 and coin2, and those showed up once I booted the game. I don't know why it's not picking up values for 5 and 6, but I'll keep playing around with it to see if I can shake it loose.

    UPDATE: I just tried to artificially create mappings in the file for player 5 inputs using maps from other controllers, and when I tried to run the game, it crashed with the message that it didn't recognize the input for "p5_button1" which was the first one on the list. So what we're seeing here is that in-game, MAME can map those inputs, but seems unable to write them to the .rc file, and furthermore, can't read them from the .rc file either.



  • @tribunal88 well, that is interesting. I see in the documentation that the allowed values for mapping digital input stops at player 4. Clearly, support is programmed into it at some level, just not in a way that lets you save the values.

    Out of curiosity, what game are you playing that allows five and six players?



  • X-Men 6-player version. You remember it from the arcade right? It used 2 TV screens to double the play area, and it was absolute chaos when you had a full boat of players. Now with 16:9 displays, it actually works pretty well putting both displays on a single screen. The framerate is fine on my Pi3 using AdvMAME 1.4 except the music sometimes has irregularities. Those anomalies go away on AdvMAME 3.2, but when I enter the tab menu with that version to map controls, AdvMAME crashes. If I could have manually edited the .rc file, I could have avoided the tab menu and possibly gotten around the crashing.



  • @tribunal88 Yeah, I remember avoiding the melee pit where this game was setup! Fun that it would otherwise work on our little RPi.

    I think you are at a dead end here on this issue. The documentation I cited above is not platform specific, so if the allowed inputs are not even listed there, I am guessing you are running into a limitation in the source, not anything Raspberry Pi (or RetroPie) specific. It does not seem like an insurmountable problem, but one that probably affects anyone using AdvanceMAME on any system. You might be the first person to try to actually setup a six player X-men.

    It is probably best to submit a ticket to the AdvanceMAME project here.



  • Done. We'll see if it goes anywhere.



  • Now THAT is support. I put in the bug report and got a quick response. 1) The crash I experienced in 3.2 was apparently fixed in 3.3 which was just released. 2) My request for up to 8 player support was patched in to the 3.4 rc1 that's in beta right now. I haven't had a chance to test it thoroughly, but I can confirm that the p5/6/7/8 entries are in the .rc file.

    Now I just need to wait for that version to ship and then for it to show up in RetroPie. Can anyone comment on the typical lag time on that?



  • AdvMAME 3.4 was released and I've manually added the binaries to the /opt/retropie/emulators/advmame/bin directory. That'll hold me over until 3.4 is compiled into RetroPie officially.

    I was able to do some testing and the 8-player support is great. This really is an excellent flavor of MAME in that it runs so well on Pi platforms.


  • Banned

    @tribunal88 I'm definitely an advanceMame convert. It runs really well and it's extremely easy to configure controls and other options via the TAB menu.



  • @AlexMurphy I agree! However, I am a fan of the CRT shader she we have for retroarch. AdvanceMAME definitely has its place though, especially for vector games. @tribunal88 i am so glad you have the 8 player setup working. All told, that was a remarkably fast turnaround from when your first attempt had failed. Bravo, everyone involved!



  • Now that RetroPie 4.2 has shipped, can we get AdvMAME 3.4 rolled into the update script?


  • Banned



  • @AlexMurphy

    Sweet! 3.3 was mentioned specifically in the release notes and I figured a couple days was too quick a turnaround. Clearly I underestimated the RetroPie team. Good on 'em!


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.

Looks like your connection to RetroPie Forum was lost, please wait while we try to reconnect.