Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Power Supply issues after screen off



  • Hey all,

    I've got a rather complicated retropie setup (detailed here). Long story short, I crammed a raspberry pi 3 into an old TV, and I'm having some problems with power consumption. The weird thing is I only get the problem after the device is left on long enough for a screen off/screen saver event to happen. Before that happens, everything runs great and I never get the lightning bolt icon appearing. But as soon as it wakes from screen saver, I get nothing BUT the lightning bolt, and performance crawls in retroarch. I tried to run TOP and watch it before and after, and nothing really jumps out at me except that retroarch is running between 65-80% cpu after, but before it only ran 50-65%. I don't think its a power supply issue, because it works fine until after screen saver kicks in. I tried switching the governor to performance, but this didn't help. Can anyone provide any ideas as to what is happening here? I'm willing to just disable the screen saver if that will solve the problem, but I'd like to solve the root cause if possible. Thanks in advance.


  • Banned

    @crono141 That's really strange behaviour. Is it just the screensaver in ES that throws up the issue or does it happen in the console / kodi / desktop too? It's good to get to the bottom of these weird issues but personally I would disable the screensaver and move on.



  • Would that be the "disable screen blanker" option under raspbiantools?


  • Banned

    @crono141 In /boot/cmdline.txtadd consoleblank=0



  • Thanks. Through a bit more trial and error, I discovered the source of the problem. I have a 5V fan powered by the Pi that I control through a script and a transistor. As soon as the fan starts to spin up is when the performance issues start. I'll have to finagle a way to power it outside of the pi. Thanks for your help.


  • Banned

    @crono141 No worries. Had a quick look at your set-up and it's complicated alright... I hope you enjoy troubleshooting!



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.