Please do not post a support request without first reading and following the advice in

  • I don't know if this is an AdvMAME issue or a RetroPie issue, but here's what I'm seeing now with the 3.3 that was just released. I have 4 controllers connected, 3 are the Matricom XBYA (Bluetooth) and 1 is a Logitech 710 wireless. In MAME when I set the controls with tab, it shows the Logitech as j1, and the Matricoms as j2, j3, and j4. All controls work as expected during gameplay. However, upon exiting, the advmame.rc file is written with all the Matricoms being j2. Logitech is still j1.

    If I assign the Logitech to a particular set of controls, then those will persist past an exit and relaunch. If I then set those controls back to one of the Matricoms (j3 or j4), they get stored as j2 in the .rc file.

    This is not the case in v 1.4, but it may have been present in v3.2.

    Can anyone confirm if this behavior is seen on AdvMAME 3.3 external to RetroPie? If so I'll submit a bug report and hopefully it will get rolled into the forthcoming 3.4 version before it ships (it' still in RC1 status).

  • @tribunal88 have you compared the device entry in the .rc files? I am thinking of device_joystick auto vs. raw or event. Have you tried these? I use a keyboard controller, so I am not saying this is your answer but I know it can make a big difference how the physical devices are recognized.

  • Good suggestion, but same result. I've gone ahead and submitted a bug to AdvMAME as well, just to be sure.

  • This was an AdvMAME issue, and the author has fixed it in the latest 3.4 beta (rc4). I had a chance to verify it this morning by dropping the new binaries into /opt/retropie/emulators/advmame/bin (after making backups, of course).

    The author is responsive to feedback. I put in a bug ticket, and it got serviced within a couple days.

  • Actually, that's an interesting side-benefit of the new way that RetroPie is working with AdvMAME; designating the current version as "advmame" without a number associated with it. This seems to allow drop-in of beta versions to work with the RetroPie interface.

  • @tribunal88 The turnaround on this is fantastic, and you are finding things that might have otherwise persisted for a long time.

    I have not updated mine since 3.2, as the install was incomplete on my system for some reason. I ended up building my own references to the .rc file using the version number in emulators.cfg. I will have to reverse this and go with a generic configuration to accommodate the rapid updates.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.