Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Daphne / Dragonrise encoder issues



  • Hello! @Clyde, I followed the user's instructions @grant2258 , I have edited the daphne.sh file and have changed it following the instructions. Then I launched Retropie-Setup -> manage packages->optional->daphne->update from source and return error in module "daphne.d" , no binaries found error.


  • Banned

    @theridernight

    try updating your setup script then try again. I had to update this to work on retropie 4.4 if 4.1 has different scripts I dont know what to say. Supplying bins is frowned upon thats why i havent linked any.


  • Global Moderator

    @grant2258 said in Daphne / Dragonrise encoder issues:

    Supplying bins is frowned upon thats why i havent linked any.

    Where did you hear that ?


  • Banned

    @mitu said in Daphne / Dragonrise encoder issues:

    @grant2258 said in Daphne / Dragonrise encoder issues:

    Supplying bins is frowned upon thats why i havent linked any.

    Where did you hear that ?

    I added a bin on the pull request a months ago so people could test and was asked to remove it from the pr. I dont want to be adding links for bins not supported by retropie.

    I do have a pull request in for these fixes on daphne at the retro pie github. I dont see any need to supply a link to bins if the changes arent accepted on the retropie end its kind of going against the github systems of getting changes implemented.

    to be fair when i first done this i had no clue how to use github am a bit better now certainly no pro though.

    here is the link for the pr

    https://github.com/RetroPie/daphne-emu/pull/15


  • Global Moderator

    @grant2258 Well, yes, in a GitHub PR there's no need for a binary file. You can add a binary release in the Releases part of your repo if you want users to test it out.


  • Banned

    @mitu

    honestly i had never used used this emulator on retropie before I just ended up fixing it when another user had problems. If you look over the forums you see many threads on controller issues on daphne. I really dont mind if the fixes are wanted or not i know the fixes work and its a good thing for all controllers. There is intructions here on how to compile it if users need to



  • Can someone give me binaries privately? (Compiling not working) .The reason is that I have a mini arcade that I can not open, or remove the microsd or perform the update of Retropie 4.1 to 4.4 as it could corrupt the microsd (it has happened to me other times). So far I have not been able to use daphne to have the control error. Thanks !!



  • @grant2258 Thank you very much. I try your solution and all works fine. Finally I can play Dragon's Lair without the keyboard :)


  • Banned

    @pinho83 said in Daphne / Dragonrise encoder issues:

    y your solution and all works fine.

    no problems at all glad your getting some use from it :)



  • @theridernight said in Daphne / Dragonrise encoder issues:

    Can someone give me binaries privately? (Compiling not working).

    I would, but I don't know how, since this forum doesn't seem to support private messages and I won't post any personal contact information openly on the net. The creator of Daphne doesn't seem to forbid the sharing of compiled binaries of Daphne as far as I researched on http://www.daphne-emu.com, so she sharing itself should be okay.

    That said, I'd prefer to work with you on that compilation problem. Could you please post your daphne.sh here in a codeblock, so we can see if you modified it correctly?

    @grant2258 @mitu and other experienced people here: Could someone please tell us where the compilation log is stored?

    The reason is that I have a mini arcade that I can not open, or remove the microsd or perform the update of Retropie 4.1 to 4.4 as it could corrupt the microsd (it has happened to me other times).

    You absolutely should think about a backup soon, as any data storage can fail anytime for various reasons, and flash memory belongs to the more fragile media in that regard. Some backup methods for Retropie are described here, some of them don't require opening your mini arcade.



  • @Clyde I know this is an old thread but I've seen you post recently and hope you will reply. I'm confused on exactly what the fix was for this. I'm very uncomfortable messing around with configurations and got confused with the multiple threads and clarifications on the changes. Can you look at your Daphne config and tell me what exactly was changed to fix this. I have Dragon Rise Encoders and have the exact same issue with Left and Right not working only on Daphne. It isn't clear on what to change and what not to change. I saw grant2258 suggested making a change to the daphne.sh but his replacement code referenced his user name and wasn't sure if that's what everyone is supposed to put. Help on this old issue, which is new to me, would very much be appreciated. I really want my Daphne to work correctly on my retropie.



  • @ULTRA-MAGNUSS Nevermind, I just stumbled on another thread that was more recent providing simple commands to run from grant2258. It's working now. Now I just have to rotate my sticks and remap the controls for all other emulators since the up and down is inverted and I'm done.



  • @ULTRA-MAGNUSS Glad to hear that. Care to share a link to that other thread in case someone else with this problem only finds this thread?



  • @Clyde
    I am in no ways taking credit for this.

    @grant2258 Posted this fix in Jan 2019

    "I have fixed a long time ago just do this to compile it and install.
    cd /home/pi/RetroPie-Setup/
    git clone https://github.com/grant2258/daphne-emu.git tmp/build/daphne
    sudo ./retropie_packages.sh daphne depends
    sudo ./retropie_packages.sh daphne build
    sudo ./retropie_packages.sh daphne install
    sudo ./retropie_packages.sh daphne configure
    sudo ./retropie_packages.sh daphne clean"

    After I ran those commands, left and right now work correctly. I wish there was a way to make Up and Down not reversed for Cobra Command but it's normal for Space Ace so I guess I just have to deal with Cobra Command's up and down reverse scheme. Thanks grant2258 for the fix.



  • @ULTRA-MAGNUSS said in Daphne / Dragonrise encoder issues:

    @Clyde
    I am in no ways taking credit for this.

    I didn't want to imply that you were. 😇 Thanks for sharing it anyways. (Although a simple link to grant's post would have been sufficient – I found it now by searching the forum for the first sentence in your quote. 😉 )



  • @Clyde sorry that wasnt really directed at you. That was just for letting everyone know that I didnt want grant to think I was taking credit for his fix. All is good :)



  • @ULTRA-MAGNUSS I don't think anyone would think you're taking credit if you cite your source with the name of the author. Cheers 🥂


  • Banned

    @ULTRA-MAGNUSS not worried about credit at all glad its working for you unfortunately thats the way these games are mapped on the hardware youll find the same issue with a lot of flying games down goes up.



  • Pls any help me to compile this to retropie 4.5.15??? and send me some heeeeelp?? :S my joy fail...



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.