Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

  • Has love been update recently? It seems to have added joystick support for a mouse, but it seems to move the screen and there are graphic glitches all over on both games I have mari0 and Mr. Rescue.

    I am running 4.1.16 on a Raspberry Pi 3, no overclock, but don't think any of that should matter. I just updated Love (March 1st). I don't believe I've seen it like this before on my other builds. Anyone else have this problem, or know of a fix? I think if I could just disable the mouse or mouse cursor it might go away.

  • administrators

    Haven't touched it in a while so it's very possible things broke when love was updated (love is notorious for breaking things on update). Generally games have to be ported with each love release. We may have to lock it to a specific version. I don't have time to test it now but feel free to try different video settings etc, to narrow things down and maybe find out what's causing it

  • Global Moderator

    @Dominus

    Looks like the last release was 10.2 on Halloween of last year. This is just one possibility, but perhaps it was configured a certain way for RetroPie and the configuration file has been reset on your setup somehow. Have you tried removing it completely, including whatever config files exist at /opt/retropie/configs/ports/love/ and adding it back again from the binary option?


  • @mediamogul yeah I just did, and still the same. I even tried copying the love files over from another install and still the same. I will have to test love on that Pi later to see if it's the same, but last time I tried it wasn't.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.