Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Kodi 17 restarts RetroPie 4.1



  • @rbwilliams07 The log will tell what's your problem with your installation. Also make sure you use a good power supply with at least 2A and without separate USB cable. If you are using "ilegall" addons, make sure you remove than before posting the log, they can be the source of your problem, and there won't be support for them here.


  • Global Moderator

    @rbwilliams07 said in Kodi 17 restarts RetroPie 4.1:

    When using any add on in Kodi 17 including youtube

    Although YouTube may have been in use when it crashed, other addons can still be responsible. Next time it crashes you can post the contents of /home/pi/.kodi/temp/kodi.log, but you should be aware that this will likely illuminate any or all addons you've been using for better or worse.

    Edit:

    @Rascas

    If you are using "ilegall" addons, make sure you remove than before posting the log, they can be the source of your problem, and there won't be support for them here.

    Much better idea.



  • @mediamogul How do I post those contents. Total Retropie noob so where do I go to get those? Can I find it by going on my computer and going through \Retropie?


  • administrators

    Before providing debug logs it is worth detailing your PSU specs - software should not be able to cause a restart. Restarts are usually down to hardware issues, such as insufficient power, or system instability due to overclocking.



  • I have a Motorola 5.1V 2.5A PSU and the 3 foot quick charge cord that came with it. It is the only PSU I have that doesn't give my Pi3 low voltage indicator when playing Super Mario World 2: Yoshi's Island (which isn't illegal as my wife owns a copy haha).



  • I love the way people are saying illegal add-ons.
    KODI (i dont knwo which number) would just exit straight back out to the retro pie screen from which I load KODI. No mention of anything on screen. In my case its not a power supply issue assumedly as I have the 2.5a supply from the cannakit.

    In terms of KODI being illegal, and thus not supported. Just think about this.
    I have music CD's, VHS and DVD all of which I have purchased and ripped to digital copies, which I use KODI to watch and listen to. But the fact that KODI can be used to infringe on copyright means its considered "illegal"

    I have ROMS, that I have not dumped myself, but that of course is not considered "illegal"?



  • @spruce_m00se Kodi is not illegal, but some addons are blacklisted/banned by the XBMC Foundation:
    http://kodi.wiki/view/Official:Forum_rules/Banned_add-ons
    In the matter of fact, in my opinion, there are some addon's that are in this list that I don't consider illegal, and there are others supported in their forum that I don't agree, like for example, Internet Archive ROM Launcher. But that is not what is in question.

    For us to help you, we need the Kodi log to see what is your problem. If your log has any of this addon's, help will not be given.



  • Hi everyone thanks for your help and advice. Turns out it was the PSU after all. I bought a new one locally a friend said they use for their PI3 and it works perfect.

    Can close those thread now.



  • @Rascas I have simply decided that loading kodi from retropie is probably too much hassle.
    I just remembered that the "reset" problem happened once I installed ds4drv.
    Before that there was no network connectivity within KODI.

    The sum of the two problems is more hassle than changing the SD card or trying the multiboot.



  • @spruce_m00se I never tried the ds4drv, it can be the problem in Kodi.
    Network connectivity is done in RetroPie scripts, it is system wide. I saw some people with problems in their networks and they fixed it changing DNSs. But again, only with the Kodi logs with debug on, we can know for sure.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.