Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

I am going bonkers with joystick setup



  • I have built a 2 player bartop arcade with a RPi 3b, Retropie 4.1, and a 2 player Easyget led joystick kit. I loaded everything, configured keyboard first. I have joysticks 1 and 2 in usb ports 0 and 1. Both are recognized as Generic Dragonrise usb controller. I configured each joystick setup as I normally do and in the ES GUI its all fine. For some reason when I load a game mapping for one joystick and buttons gets changed even when I exit to ES it is still different. I have searched and searched to the point of frustration. I saw a usb quirk line to add to the cmdline.text and that didnt help. I have reset the control mapping in retropie setup and started over about 10 times and so far nothing has worked. I feel like I am overlooking something simple.

    Any help will be greatly appreciated, and I do apologize if this has been covered but my searching had led me to making the post.



  • @Jonni-Nitro Which emulator and which game are you testing with?



  • Well, apparently I am an absolute idiot. I assumed that when I connected the buttons to the usb controller that it didnt matter in what order because the mapping would set it anyways. So being the neat freak that I am, I wired things to look pretty which means they were connected in a different order. It wasnt until I had already posted this and was staring at my wiring did it finally click that could be what is happening. Now I dont know if its supposed to work like that or if its the fact the devices show up as the same usb id, but I switched player 2 to match player one and everything is working. It seems to be correct because even in game the exit command (start/select) only works from P1.



  • just FYI, I have an issue ongoing whereby in ES I map the controller then in emulators that seems to vary.
    I have also found that upon mapping player 2 controller the player 1 controller mapping changes.
    I am hoping to have enough time to simply write my own config files and set them for each emulator manually, hopefully this will fix it, but for now nobody wants to play with me anyway so I dont need a player two, lol , im off to cry myself to sleep.



  • So just to confirm, this is still not working?

    I have the same exact setup and the issue I am having is my button mapping changes for player 1 but not player 2. Player 2 is working perfect.

    The config file is accurate and the lsusb command shows them both:

    Bus 001 Device 005: ID 0079:0006 DragonRise Inc. Generic USB Joystick
    Bus 001 Device 004: ID 0079:0006 DragonRise Inc. Generic USB Joystick

    My config file is there too:

    /opt/retropie/configs/all/retroarch-joypads

    DragonRise Inc. Generic USB Joystick .cfg

    input_device = "DragonRise Inc. Generic USB Joystick "
    input_driver = "udev"
    input_l_btn = "2"
    input_load_state_btn = "2"
    input_start_btn = "8"
    input_exit_emulator_btn = "8"
    input_up_axis = "-3"
    input_a_btn = "5"
    input_b_btn = "4"
    input_reset_btn = "4"
    input_down_axis = "+3"
    input_r_btn = "6"
    input_save_state_btn = "6"
    input_r2_btn = "7"
    input_right_axis = "+0"
    input_state_slot_increase_axis = "+0"
    input_x_btn = "1"
    input_menu_toggle_btn = "1"
    input_select_btn = "9"
    input_enable_hotkey_btn = "9"
    input_y_btn = "0"
    input_left_axis = "-0"
    input_state_slot_decrease_axis = "-0"
    input_l2_btn = "3"

    Any thoughts?



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.