Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Retropie on Raspberry Pi Zero W freezing



  • I upgraded to a Raspberry Pi Zero W about a week ago from a Pi Zero. Was looking forward to the bluetooth and Wifi, but have been having problems with the Pi Zero W. Retropie will freeze up (I've had 2 different ways now) after being left on a rom selection screen for too long. Before version 4.2 of Retropie was released I tried a work around I found on Youtube that had me replace 4 of the files with ones from Raspbian Lite. This did not solve the issue. I was hoping that updating to 4.2 would solve the freezing issue. But now the system will kick me out to command prompt when left on a rom selection screen (about a minute of waiting on a screen) and say "Illegal Instruction". No keyboard or mouse input will be accepted.

    Did I mess up the update by trying to install the original work around or is this a known issue? Do others have their Raspberry Pi Zero W's working fine with Retro Pi?

    I contacted the seller of the unit and they said that no version of Retropie works currently with the Zero W. This was before 4.2 came out. Is this still the case?

    Short of doing a fresh install I am stumped.


  • administrators

    @zerd_sword runs fine on my pi zero. Just start with a fresh 4.2 pizero image and see if it's resolved.



  • Using the 4.2 img file on my Pi Zero and Pi Zero W, all good here.



  • Hi, i bought an brand new Raspberry Pi Zero W too. I tried combinations with two different SD cards, two different power supplies, 3 differents images and fresh installs. I have one problem and that it's crashing randomly in the Retropie menu. The crashes happens after an fresh install trying to setup any controller (original Xbox or Clone Snes) or after setting up the controller and just going up or down in the menu or just waiting. It always crashes within 10 minutes. My last test was an fresh install with version 4.2 (Zero version). The SD cards were formatted and imaged with the suggested tools. I wish i could test my SD card with another Raspberry Pi Zero W board. I have also tested an fresh install of Raspian, the OS works slow and playing an Youtube movie on 360p will let the Raspberry Pi Zero W freeze too.

    I have mailed my supplier, but they think that Retropie still need to be optimized for the Raspberry Pi Zero W. My main problem is freezing of the whole system by just running Retro Pie 4.2 inthe menu screen. I have ask my supplier to test with an other Raspberry Pi Zero W board. I am still waiting for an reaction.

    Regards,

    Wai



  • I gave it today another test. I booted the Raspberry Pi Zero W, made sure there was no BT or Wifi connected (just as an test) i did not scroll a lot in the menu, i went to the 8 bit NES emulator, played Donkey Kong for 30 minutes, then left the emulator with the start and select button, went to the SNES emulator, started Final Fight and played it for 15 minutes, left the emulator, back in the Retro Pie menu i went up and down with the D Pad ( using an Wired Clone SNES pad) then for an test i just hold the D pad button down and the selection rule went down fast and then suddenly the screen went black and went to an commando screen with the following warning :

    emulationstation : /home/pi/Retropie-setup/tmp/build/emulationstation/es-core/src/resources/font.cpp:129: static UnicodeChar font::readUnicodeChar(const string&, srd::size_t&): Assertion '(c & 0xC0) != 0x80' failed

    Aborted

    And under these warnings i saw the Retro Pie logo with the status of the memory. It was only 50% used of the 8 GB SD card and the tempature of the CPU and GPU where both 51 degrees/123 F, 92 processes and then followed by and prompt.

    I hope somebody can help me :)


  • administrators

    @lammetje it crashed due to some issues with your ROM filenames. Perhaps some have the wrong character encoding. Make sure you don't have any strange characters in the filenames.



  • @BuZz thanks for the tip, i will check the rom names. However when i scrolled the RetroPie menu down, it was not in any rom list, but i will check of i can simulate this problem without any roms on the SD card.



  • I did an fresh install of the image of Retropie 4.2 on the Raspberry Pi Zero W, booted the image, configured an wired clone SNES controller, entered the Retropie configuration screen, went with the D pad up and down over the options and Retropie froze within 1 minute over one of the option that were highlighted.

    I did not choose anything. It was just to test if the Raspberry Pi Zero W with Retropie 4.2 in the configuration menu would crash again without roms or changing specific settings.

    The LED of the Pi does not light up.

    I did an second test with another SD Card which was branded by an company that sell Raspberry Pi systems. This install also froze in the configuration menu screen while moving the D pad up and down.



  • I did an second test with another SD Card which was branded by an company that sell Raspberry Pi systems. This install also froze in the configuration menu screen while moving the D pad up and down.



  • Pi Model or other hardware: Raspberry Pi Zero W (motherboard version 1.2)
    Power Supply used: SOS Solution Branded for Pi use, 5v, 3.0 amp max.
    RetroPie Version Used : 4.2
    Built From: Pre made SD Image on RetroPie website
    retropie-4.2-rpi1_zero.img.gz, two different SD cards used.
    USB Devices connected: Game Controller
    Controller used: Clone SNES Controller or Xbox 360 controller
    Error messages received: Screen freeze in configuration screen or any screen
    Log found in /dev/shm/runcommand.log (if relevant): - need to check
    Guide used: n/a
    File: n/a
    Emulator: n/a
    Attachment of config files: n/a
    How to replicate the problem: boot RetroPie, go to the Configuration screen, move the D pad up and down continues, until the screen freezes or just wait, but by moving the controller the freeze will occur within minutes randomly after many reboots.



  • I'm not certain if I understand your original problem, but as the only constant in your setup is the Clone SNES Controller, you may test unplug it and use a keyboard instead - just to exclude this as possible error source?

    May it be, that the crash you had earlier (the font thing) doesnt have to do anything with the remaining problem in the configuration menu?



  • I've also had quite a few bad Raspberry Pi Zero's (not the W model which I just picked up 5 of to mess around with) - brand new out of the silver plastic bag = defective.

    I would also order a ~$8 Samsung EVO (or similar higher-end brand) SD card to limit cheap SD cards as being a problem as well.



  • @midstar thanks for your reply, i updated the reaction. I also have the same problem with an Xbox360 controller. So the main problem is freezing of Retropie any moment in the menu and sometimes in an emulator, but i try to limited the problem by simulating the freeze of Retropie by moving any of the two controllers up and down with the D pad in the configuration menu. If i try an USB keyboard then it won't be regonized by Retropie in the menu. It does work if i want to fill in an Wifi password in the terminal mode.

    The freeze will also happen after Retropie is booted and just waiting in any menu with or without roms uploaded to the SD card, but ofcourse it won't be noticed untill you do something with Retropie.

    I can boot retropie, go quickly to an emulator,choose an game and enjoy it, but it will freeze after an while. So the main problem is the random freeze in Retropie. I tried an Samsung 8GB class 10 SD card and an SD card which is sold and branded by an company that sell Pi systems with installed SD cards, both also will freeze Retropie.

    I hope this makes it more clear.



  • I am still having what looks to be the same problem as Lammetje. I have tried a complete fresh install of Retropie 4.2 (no roms installed). It will freeze in a few minutes on the menu screen. I tried updating all install packages. That did not help. I tried a custom 4.1.20 (found here https://retropie.org.uk/forum/topic/8878/new-4-1-20-retropie-images-for-testing). Did not work any better. I have tried doing a fresh install of Raspbian and putting Retropie on top of that. Same problem of freezing on a menu screen. Spent a lot of time so far trying to figure this out. All of these configurations work fine on my ordinary Raspberry Pi Zero.



  • Hi Zerd_Sword,

    I want to try my SD card and controllers with another Raspberry Pi Zero W, so i ask my reseller if they want to help me, but they think that the software is not stable yet and i should try Rasbian to see if my Pi Zero W works. So i am stuck at the moment :( i can take the risk to buy another one to test with or buy another SD card. I will wait until next week and if my reseller doesn't respond, then i will fill in an PayPal case.

    If you or someone else on the forum found something new about the menu freezing problem with the Pi Zero W, please let me know !

    Cheers !



  • I bought a new Raspberry Pi Zero W and the problem with the menu freezing does not happen anymore while using the same SD card, powersupply and SNES USB controller. I tried also an couple games, Kodi 17 rc2 and it works all great !

    The only thing that still goes wrong is with an orginal wired Xbox360 controller. When i plug it in and start Retro Pie 4.2 , RetroPie detect it and when i configure the buttons, it will skip the left trigger, goes to the next button and the menu still freeze and i have to hard reboot the Pi Zero W. I only tried configuring it once with the Xbox controller, because i wanted to focus on the other setup that now works fine ! So i think it's worth to try another Raspberry Pi Zero W while troubleshooting this kind of problem.



  • I've ordered a new Pi Zero W. Will reply when it arrives and I have time to test. Fingers crossed.



  • Well, turns out it was just a bad Raspberry Pi Zero W. I received my new one and tried it out with a couple of the images that were not working with the original board. Works perfect. Left it on for extended periods to test and it never froze. Glad that is solved!



  • @zerd_sword hi!

    I have this very same issue with a recent purchase.

    Got a RPi Zero W v1.1 and Retropie hangs after a while. It occurs while emulating SNES and NES (the only ones I tested), copying data via samba, browsing scraped metadata, and even while sitting idle on the ES screen. It seems random but it appears to happen after the system is warmed up, although I removd the official case I got to no avail.

    I only have the one so I have no means to verify other board does work indeed, so I was wondering whether you figured out how to identify the faulty hardware. Was there anything different on the new one? Different manufacturer maybe?

    Here's a picture of my board printed data: https://drive.google.com/file/d/1iSIXzlZtVigopNxecTbHC9xb4ylrXizs/view?usp=drivesdk

    If you have any info, please advise.

    Thanks!



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.