Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Retropie on Raspberry Pi Zero W freezing



  • Pi Model or other hardware: Raspberry Pi Zero W (motherboard version 1.2)
    Power Supply used: SOS Solution Branded for Pi use, 5v, 3.0 amp max.
    RetroPie Version Used : 4.2
    Built From: Pre made SD Image on RetroPie website
    retropie-4.2-rpi1_zero.img.gz, two different SD cards used.
    USB Devices connected: Game Controller
    Controller used: Clone SNES Controller or Xbox 360 controller
    Error messages received: Screen freeze in configuration screen or any screen
    Log found in /dev/shm/runcommand.log (if relevant): - need to check
    Guide used: n/a
    File: n/a
    Emulator: n/a
    Attachment of config files: n/a
    How to replicate the problem: boot RetroPie, go to the Configuration screen, move the D pad up and down continues, until the screen freezes or just wait, but by moving the controller the freeze will occur within minutes randomly after many reboots.



  • I'm not certain if I understand your original problem, but as the only constant in your setup is the Clone SNES Controller, you may test unplug it and use a keyboard instead - just to exclude this as possible error source?

    May it be, that the crash you had earlier (the font thing) doesnt have to do anything with the remaining problem in the configuration menu?



  • I've also had quite a few bad Raspberry Pi Zero's (not the W model which I just picked up 5 of to mess around with) - brand new out of the silver plastic bag = defective.

    I would also order a ~$8 Samsung EVO (or similar higher-end brand) SD card to limit cheap SD cards as being a problem as well.



  • @midstar thanks for your reply, i updated the reaction. I also have the same problem with an Xbox360 controller. So the main problem is freezing of Retropie any moment in the menu and sometimes in an emulator, but i try to limited the problem by simulating the freeze of Retropie by moving any of the two controllers up and down with the D pad in the configuration menu. If i try an USB keyboard then it won't be regonized by Retropie in the menu. It does work if i want to fill in an Wifi password in the terminal mode.

    The freeze will also happen after Retropie is booted and just waiting in any menu with or without roms uploaded to the SD card, but ofcourse it won't be noticed untill you do something with Retropie.

    I can boot retropie, go quickly to an emulator,choose an game and enjoy it, but it will freeze after an while. So the main problem is the random freeze in Retropie. I tried an Samsung 8GB class 10 SD card and an SD card which is sold and branded by an company that sell Pi systems with installed SD cards, both also will freeze Retropie.

    I hope this makes it more clear.



  • I am still having what looks to be the same problem as Lammetje. I have tried a complete fresh install of Retropie 4.2 (no roms installed). It will freeze in a few minutes on the menu screen. I tried updating all install packages. That did not help. I tried a custom 4.1.20 (found here https://retropie.org.uk/forum/topic/8878/new-4-1-20-retropie-images-for-testing). Did not work any better. I have tried doing a fresh install of Raspbian and putting Retropie on top of that. Same problem of freezing on a menu screen. Spent a lot of time so far trying to figure this out. All of these configurations work fine on my ordinary Raspberry Pi Zero.



  • Hi Zerd_Sword,

    I want to try my SD card and controllers with another Raspberry Pi Zero W, so i ask my reseller if they want to help me, but they think that the software is not stable yet and i should try Rasbian to see if my Pi Zero W works. So i am stuck at the moment :( i can take the risk to buy another one to test with or buy another SD card. I will wait until next week and if my reseller doesn't respond, then i will fill in an PayPal case.

    If you or someone else on the forum found something new about the menu freezing problem with the Pi Zero W, please let me know !

    Cheers !



  • I bought a new Raspberry Pi Zero W and the problem with the menu freezing does not happen anymore while using the same SD card, powersupply and SNES USB controller. I tried also an couple games, Kodi 17 rc2 and it works all great !

    The only thing that still goes wrong is with an orginal wired Xbox360 controller. When i plug it in and start Retro Pie 4.2 , RetroPie detect it and when i configure the buttons, it will skip the left trigger, goes to the next button and the menu still freeze and i have to hard reboot the Pi Zero W. I only tried configuring it once with the Xbox controller, because i wanted to focus on the other setup that now works fine ! So i think it's worth to try another Raspberry Pi Zero W while troubleshooting this kind of problem.



  • I've ordered a new Pi Zero W. Will reply when it arrives and I have time to test. Fingers crossed.



  • Well, turns out it was just a bad Raspberry Pi Zero W. I received my new one and tried it out with a couple of the images that were not working with the original board. Works perfect. Left it on for extended periods to test and it never froze. Glad that is solved!



  • @zerd_sword hi!

    I have this very same issue with a recent purchase.

    Got a RPi Zero W v1.1 and Retropie hangs after a while. It occurs while emulating SNES and NES (the only ones I tested), copying data via samba, browsing scraped metadata, and even while sitting idle on the ES screen. It seems random but it appears to happen after the system is warmed up, although I removd the official case I got to no avail.

    I only have the one so I have no means to verify other board does work indeed, so I was wondering whether you figured out how to identify the faulty hardware. Was there anything different on the new one? Different manufacturer maybe?

    Here's a picture of my board printed data: https://drive.google.com/file/d/1iSIXzlZtVigopNxecTbHC9xb4ylrXizs/view?usp=drivesdk

    If you have any info, please advise.

    Thanks!



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.