Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

8bitdo configured correctly in ES but not in-game on 4.2 (?)



  • Hi!
    I've used 8bitdo controllers since RetroPie 2.x, but on 4.2 I've run into a strange problem.
    The controller is paired and works fine both in EmulationStation as well as the terminal testing utility. The gamepad config file also looks fine, but as soon as I start an emulator the controls are all mixed up.
    The D-pad still works as before, so I can move around. But apart from that, the only button that works is 'B', which is somehow set to 'START' instead. None of the other buttons do anything.
    I have this issue on a Pi Zero W with a 8bitdo Zero, but a friend had the same on a Pi 3 with a NES30 Pro. I got both of these controllers working on a Pi 3 without issues on a previous version of RetroPie which leads me to believe it could be due to some change since 4.2.

    Anyone have any ideas? Could there be some "master configuration" file that have higher priority than the configuration file created by ES?



  • @jolny what emulators are you using? Hit tab on the keyboard (or select andnyhe button you have set up as your Y button I believe ) go to quick menu, controls and see how the controls are mapped for each emulator. Make changes and save to core. This will update your controls for each system. This only work for emulators that start with "LR" which are libretro cores.


  • administrators

    @jolny switch the 8bitdo hack mode in the bluetooth settings, and reconfigure - https://retropie.org.uk/docs/8Bitdo-Controller/

    also - https://retropie.org.uk/forum/topic/3/read-this-first



  • I can't comment on that particular problem, but I did have a few issues following the Wiki to the letter with some connectivity issues on my NES30, and disconnection problems with my SFC30. On both those occasions I hooked them up to my computer and re-installed the firmware for both pads, booted Retropie and removed both control pads. I then shut down, restarted and re-added both pads, one at a time, with a restart in-between. This cured both issues and both pads now work flawlessly.

    Whilst I know thats not a direct solution to your problem, it may be worth a go for the sake of 15 minutes work.

    ::Edit: Idiot-I completely overlooked the fact Buzz had posted the same thing....



  • Sorry for not replying earlier guys, and thanks for the replies!

    @TMNTturtlguy I tried pressing TAB when in-game (lr-quicknes). Nothing happens. I can control the game fine from the keys however. I'll try to find Select+Y on the keyboard!

    @BuZz I removed the device, switched 8bitdo hack ON and added it back again. Didn't help. Then I realized I need to remap the controls in ES, which worked. Thanks!

    @Danorak1981 yes, updating is the best fix! But the Zero gamepads can't be updated I'm afraid.
    Funny thing, I have one older Zero gamepad and one slightly newer. The hack is needed for the old one but not the new one (and the Zero can't be updated).



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.