Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

  • Hello,

    I've installed RetroPie as described on Ubuntu 16.04.02.
    but I don't like, that it first boots into Unity and then starts Emulationstation as an application.
    I've tried to let ubuntu behave like raspbian and configured to boot directly into tty1.
    To do so I changed in the file
    /etc/default/grub
    to
    GRUB_CMDLINE_LINUX_DEFAULT="text"

    then updated grub with:
    sudo update-grub

    And changed systemd to not load the desktop with ...
    sudo systemctl enable multi-user.target --force
    sudo systemctl set-default multi-user.target

    tada! ubuntu now boots to tty1 without starting unity.
    startx is also working and I see emulationstation starting. The only Problem that exists, emulationstation can't "see" any inputdevices and don't accept any Input.

    Does anyone know how this is configured in Raspbian / Retropie ?
    I've tried already to read the source but didn't find any interesting part, that would indicate any special configuration for that.


  • How about un-installing unity and installing something like open box to run? maybe that will bring back the inputs.


  • i myself have been trying to build on top of ubuntu server edition ... start fresh


  • Hi damanbaird,

    please could you tell me how you've done that?

    I just installed ubuntu server on my nuc it was a standard installation with the exception, that I installed git dialog and libsdl2-dev manuallly befor doing Retropie-Setup.
    After installation of RetroPie finished i tried to start with "emulationstation" from tty1 and get those errors:

    lvl0: Error initializing SDL!
    No available video device
    lvl0: Renderer failed to initialize!
    lvl0: Window failed to initialize!

    So I've tried your advise to install additionaly openbox and xinit. I configured emulationstation from RetroPie-Setup to start automatically.
    Now with startx openbox starts, but emulationstation is not starting !?


  • Install ubuntu server or when you install ubuntu desktop, remove the kde and x system components from the installer list.


  • @masteryoer said in RetroPie on Ubuntu without Unity:

    Install ubuntu server or when you install ubuntu desktop, remove the kde and x system components from the installer list.

    I've just installed ubuntu SERVER once again and installed Retropie, but emulation station is still not starting, with the same error Message as in my first Post.

    Please could you provide some more detailed information how you installed it?


  • Is here a reason you are using ubuntu? Retropie image and ubuntu are both Debian based so they have nearly the same code base and functionality.


  • Yes, I try to get it running on my nuc (x86), so I can't take the preconfigured RetroPie Image.
    Using Debian causes the same errors. I took Ubuntu, because its more or less recomended by the RetroPie wiki.


  • @Assault said in RetroPie on Ubuntu without Unity:

    Yes, I try to get it running on my nuc (x86)

    My friend @R1n0X installed RetroPie on his NUC using the MX Linux as the OS and seems to be very satisfied.


  • @Assault I do not know if im allowed to post or share links but i followed some of this .... https://thepcspy.com/read/building-a-kiosk-computer-ubuntu-1404-chrome/


  • hi!
    I solved this problem as follows: сreated file ~/.xinitrc with the content:
    #!/bin/sh
    exec emulationstation

    Now when the command startx runs automatically ES


  • @Logof Thanks! that actually helped! Do you know how to disable the mouse cursor when x-starts? i hate seeing the cursor right as everything starts up.


  • @damanbaird said in RetroPie on Ubuntu without Unity:

    Do you know how to disable the mouse cursor when x-starts?

    How are you invoking X?

    if it's with startx you can try startx -- -nocursor. If you are invoking startx in a big command (as in that guide about ubuntu kiosk you linked above) the -- -nocursor part comes in the end of the startx command.


  • @meleu thanks let me try that.


  • OK, I"m about done with my ubuntu server Retropie image , if anyone is interested i can share a iso or img file from dropbox or other host.... without roms and stuff of course :D.


  • @damanbaird I think a small guide or at least the steps you've taken to reach this stage would be more appreciated. We are tinker guys here. :-)


  • I'd appreciate both a guide and the iso for easy installation. Wherever you can provide is fine.


  • A guide would probably be easier for me since i have slow upload speeds living out in the middle of no-where. Guess ill whip out Libre Office and start typing away


  • AS it is my Retropie system has several qualities, 1. boots straight to emulationstation. 2. boots without any hint as to the OS the system runs on. 3. pretty much like how it does on Raspberry Pi's.


  • I'm in the same boat, but still just end up at the desktop when I add the .xinitrc bit.
    I would love to see your setup instructions, and/or grab an iso!

    Thanks!

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.