Please do not post a support request without first reading and following the advice in

Retropie setup in Debian Stretch (Testing) requires gcc4.9, g++4.9 etc but only has gcc6

  • I was trying out Debian stretch and decided to try to install retropie if it would work. Unfortunately, the install would not proceed because the retropie setup script requires gcc4.9+ whereas Debian Stretch only has gcc6.

    Any chance that the script would be able to work in Debian?

  • In your situation, I would try to remove / replace all checkes in the RetroPie-script. I then try to install it.
    I think your chances are not to bad to get it running.

    But why do you have to use Debian Testin !?

  • I am trying out testing since stable did not work for me- though I shall take a look into it again.

    So in stretch / testing look into
    for the line containing

    and change it into

    for the install to push through.

    Unfortunately it asks for libpng12-dev which Debian Stretch does not have.

  • So the best desktop distro to run retropie right now for me is 16.10
    Ubuntu-gnome 16.10 - hdmi audio works, pretty much retropie works in my limited testing
    Ubuntu-gnome 17.04 - should work but some packages that I need (kodi, gnome-session-flashback etc) might not be ready as it is not yet released
    Ubuntu 16.04 - experienced some freezes in emulationstation when alt tabbing
    Debian gnome 8 Stable - crashes after a few seconds will take a look again
    Debian 9 Stretch testing - uses gcc6, no libpng12-dev

  • administrators

    Debian stretch won't be supported until Raspbian switches over to it. The recommended system for running RetroPie on is Raspbian, and that is the OS that most of the testing for the RPI is done on (and the only OS where prebuilt binaries are available).

    Assuming you are referring to the RPI as you don't provide details.

  • My apologies. I am running it on a laptop and trying which distros would work.

  • administrators

    @vampireJ For a laptop, Ubuntu is recommended as I use that for development (So it's the most tested). 16.04 or better should be fine.

    Note, when posting for advice in the future please read (as agreed when registering). Things like hardware platform are important and in this case it would have saved me time.

Log in to reply

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.