Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Announcing Pegasus Frontend



  • Weekly update! This time there have been several fixes related to portable and global metadata files:

    • Portable launch command improvements
      • Relative launch commands and relative working directories are now consistent on all platforms (ie. always relative to the metadata file).
      • Note: like on most *nix systems, standalone executable names (eg. myemulator in launch: myemulator {file.path}) refer to globally installed programs (something in $PATH), while those starting with dot-slash (eg. ./myemulator in launch: ./myemulator {file.path}, or .\myemulator.exe on Windows) refer to executables in the same directory as the metadata file.
      • There are still some possible improvements there, but should work fine now for the most common cases.
    • Added support for multiple metadata files in [configdir]/metafiles. Any files whose name ends with .metadata.txt or .metadata.pegasus.txt there will be read (eg. snes.metadata.txt, etc.).
    • Added support for asset searching by game title. Game assets can now also be stored under [gamedir]/media/[gametitle]/. Just make sure there are no two games with the same name in the same collection.
    • Fixed collectionless and duplicate game entries remaining in memory.
    • Fixed some possible threading issues on Windows.
    • Fixed assets.videos and assets.screenshots not recognized in metadata files.
    • Fixed incorrect list of publishers for Steam games.
    • Fixed the Settings screen still referring to collection files.
    • Improved the asset support of the metadata converter site. Added support for ES2's video and marquee tag.
    • Themers: the loading-spinner.png is no longer a globally available image. Please ship all files you use with your theme.
    • Various small fixes and optimizations.

    @msheehan79 These changes should fix the relative launch path issues (tested on Windows 7).

    @nemo93 Sorry I couldn't write a longer reply yesterday!

    By reading the Pegasus doc I've found the object assets could have the videos property to be set. Yet if you go with assets.videos then it won't work you have to rely on assets.video (without an "s") instead.

    Also the <marquee> and <video> tags from ES2 gamelist.xml are not converted using the online converter.

    Ok, both of these should be fixed now, thanks!

    looks like the directory property does nothing as if I don't add the full path+roms or full path+asset in the value then nothing happens (and I got a msg about "missing file <game file>" in the lastrun.log.

    directory will make the collection look for files with matching extensions in that place too, in addition to the metadata file directory. The file: entries still have to be either absolute or relative to the metadata file. If file finding still seems to be incorrect, feel free to post your file and I'll take a look.

    after using the online converter I realize I have to double the dot as the example above to add another new line to get the same I have with ES2.

    Could you post an example (screenshot/XML)? It seemed to be correct for me (though I don't use ES much these days).

    any way to define also a "global" assets directory for Pegasus to look into? so that I don't have to add absolute path for each asset.

    The problem with that is when there are games/files with the same name in different collections, it can't be decided which one does an asset belong to. Maybe a custom asset directory option could be added in the future instead.

    I tried to create a "metadata.amiga.txt" file so that I could store all metadata files under the "metafiles" directory instead of inside the "metafiles/<system>/" directory. This doesn't work.

    Just added support for that recently, should work now (in a different filename order).

    how easy would it be to add a new "system"? I mean I'd like to add my own "sfc" and "PC Engine CD rom rom" systems to Pegasus default theme. Should I just create a specific collection in a metadata.txt file? If so how should I set the logo for that system?

    Yes, you can just create a new collection with whatever name and short-name you wish. There's no custom logo support in the main theme yet, but you can download it from here and add a matching SVG under assets/logos/.

    @5schatten Yes, the standard output is colored as it's intended to show on the screen. However, the log is also saved to ~/.config/pegasus-frontend/lastrun.log, without colors (maybe you might want to link it under /var/log/). If you wish you can also disable the console output with the --silent option.



  • @fluffypillow Is internal scraping coming at least in the way for logos/screenshots? Pegasus can use ES's scraped art which is really great but I had to scrape logos/screenshots on pc then get a renamer app to rename them accordingly which was very time consuming. I doubt new users will go through it.



  • @fluffypillow said in Announcing Pegasus Frontend:

    @Meldrak @nemo93 I accidentally broke absolute launch commands yesterday, but they should work now (alpha11-24). Please try again whether it fixes the issue for you too.

    Thanks it works now, but now I have a issue with Cemu
    cemu always crash just after showing the loading screen of the rom

    2019-03-18T22:56:24 [i] Executing command: [`E:\games\wiiu\cemu\cemu.exe`,`-g`,`E:\games\wiiu[ARPP0101]\code\red-pro2.rpx`,`-f`]
    2019-03-18T22:56:24 [i] Process 11544 started
    2019-03-18T22:56:24 [i] ----------------------------------------
    2019-03-18T22:56:29 [w] The external program `E:\games\wiiu\cemu\cemu.exe` has crashed
    2019-03-18T22:56:29 [i] ----------------------------------------
    2019-03-18T22:56:29 [i] The external program has crashed on exit, with exit code -1073741676
    

    the strange thing is that cemu doesn't generate any log file
    and executing the command from a bat file works well

    is anyone manage to run wiiu games from Pegasus?



  • @Darksavior if talking about completely new users, wouldn't it be more common to assume they will just use eg. Skraper and copy its output, rather than downloading a different frontend to use its built-in scraper (if it still works) to get half the assets in one format, then use a different standalone skraper to get the rest in another, then manually copy/move/rename the files into a third kind of asset structure? :)

    But yes, in the long term a cross-platform built-in scraper would be nice. I'll likely make it as a separate app first for testing though, but if it ends up working fine it could be integrated too.

    @Meldrak the E:\games\wiiu[ARPP0101]\code\red-pro2.rpx looks suspicious to me, isn't a \ missing there or is that intentional? If that turns out to be the problem, could you post your metafile?



  • I love this front end, the only issue I found in small 8 game collections arround 4 to 8 games after changing one single page back and forward the images now appear bigger needing to do so two pages to avoid the bug, other than that I LOVE this frontend and I hope it matures into a beutyfull frontend capable of rivaling ES as the default RetroPie frontend



  • @fluffypillow I don't believe any scraper uses Pegasus's naming scheme for logos/screenshots. I had to use a renaming utility which was very inconvenient.



  • @fluffypillow sorry I didn't see that, but I Don't know why it was not working, as my metadata is correct
    file: ./[ARPP0101]/code/red-pro2.rpx
    I tested again today and it works rom path is correct, I just rebooted Windows….

    could you add icons for wiiu, ps2 and n3ds in your default theme?



  • @fluffypillow Should the following launch all GB and GBC games as Game Boy Color in terms of RetroArch settings if placed in the GBC folder?

    collection: Game Boy Color
    shortname: gbc
    extensions: gbc, zip, GBC, ZIP
    command: /opt/retropie/supplementary/runcommand/runcommand.sh 0 _SYS_ gbc "{file.path}"
    
    collection: Game Boy
    shortname: gb
    extensions: gb, zip, GB, ZIP
    command: /opt/retropie/supplementary/runcommand/runcommand.sh 0 _SYS_ gbc "{file.path}"
    
    


  • @fluffypillow great to hear the relative path is working now!

    When I have a chance I'll update my metadata files back to the relative paths to give it another shot and confirm all is working with the latest builds. Thanks!



  • @sergioad yes that's a very old bug in the main theme, I really should fix it some of these days.

    @Darksavior yes, no scraper supports Pegasus yet, but that's also why there's support for ES's and Skraper's output, that most of them do. Hopefully the situation will get better in the future :)

    As for renaming the files, perhaps that could scripted in some way to save time?

    @Meldrak I've just pushed some updates, could you check the launching with the latest version (alpha11-34)?

    Yes, could be added, some of them were also requested by others so will take a look on them.

    @hooperre both collections have same launch command, so they should (unless RetroArch itself does some additional logic).



  • @fluffypillow by the way could you add an option to hide the mouse cursor? In RetroPie I rarely use a mouse, maybe it could be implemented by a flag being pegasus-fe --nocursor; another great posible flag could be --nologs to avoid the pegasus logs in the background (the text that appears when launching a game or a RetroPie settings app) making the UX cleaner



  • @sergioad yes the cursor hiding will come eventually as an option under Settings, to make it easier. There's also already a --silent flag to turn off log printing (or you can just redirect it to /dev/null).



  • @fluffypillow excelent! thanks, please @ me when you implement the cursor hiding please



  • @fluffypillow Just wanted to pass along that I updated my metadata.txt files to use relative paths and all is working as expected now. Thanks for fixing this!!



  • hey fluffy! long time i've posted smth here ...
    i've "completed" my rom collection on a nvidia shield tv and wanted to add pegasus as a frontend (again), but it's totally changed it seem :D the only thing i can see on all themes is the main menu ...what do i need to change / update to see my roms again :D ?

    found smth useful in the doc, i'll try it on my own first :)

    edit: ok, tried it, but still nothing. My pegasus frontend is totally empty ...no systems, no roms nothing. What am i doing wrong? o.O



  • @sergioad sure, will try to. There's also this issue you can subscribe to to get notified the moment it gets fixed.

    @Purg-Derren yes there've been a few changes since alpha 10, you can find the details and update help on this page. But feel free to ask if you run into any troubles!



  • @fluffypillow Ok, thanks



  • @fluffypillow figured it out, finally :)
    any solution on preventing pegasus to "crash" on android after closing an emulator?



  • @Purg-Derren also having this issue. By chance are you on shield TV or a different device cause I'm on shield and was wondering if it was an isolated issue?



  • @jerzeeloon i'm on shield, but also had tha issue on a different android based streaming device time ago



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.